Problem A

Posted tansanity

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Problem A相关的知识,希望对你有一定的参考价值。

Problem Description There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. <br><br>We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.<br>  
Input The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.<br><br>Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.<br>  
Output You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. <br>  
Sample Input
  
   3
0 990 692
990 0 179
692 179 0
1
1 2

  
 
Sample Output
179
简单题意:   现在有N个村子,编号为1-N,需要建立公路使得每两个村子可以相互连通。现在给出一个各个村子之间的距离地图,以及已经连接的村子的编号。现在需要编写一个程序,求出使得任意两个村子可以连通的所修建的最短的公路距离。 解题思路形成过程;   和老师课堂上讲的算法有异曲同工之处,课堂上的是求出最小连通图,而本题是求出最小生成树。但是,为了求出最短距离,就少了一部分代码。所以,用上数据结构中的Prim算法,求出最小生成树,然后解决问题。 感想:   图这一个专题感觉会比以往难写算法。只有见得多了,才可以运用已知求出未知。 AC代码: #include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=110;
const int INF=0x3f3f3f3f;
int n,ans;
int map[N][N],dis[N],vis[N];
void Prim()

    int i;
    for(i=1;i<=n;i++)
   
        dis[i]=map[1][i];
        vis[i]=0;
   
    dis[1]=0;
    vis[1]=1;
    int j,k,tmp;
    for(i=1;i<=n;i++)
        tmp=INF;
        for(j=1;j<=n;j++)
            if(!vis[j] && tmp>dis[j])
                k=j;
                tmp=dis[j];
           
        if(tmp==INF)
            break;
        vis[k]=1;
        ans+=dis[k];
        for(j=1;j<=n;j++)
            if(!vis[j] && dis[j]>map[k][j])
                dis[j]=map[k][j];
   

int main()

    while(~scanf("%d",&n))
       
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                scanf("%d",&map[i][j]);
        int q,a,b;
        scanf("%d",&q);
        while(q--)
       
            scanf("%d%d",&a,&b);
            map[a][b]=map[b][a]=0;
       
        ans=0;
        Prim();
        printf("%d\\n",ans);
   
    return 0;

以上是关于Problem A的主要内容,如果未能解决你的问题,请参考以下文章

Problem D

BZOJ1196 [HNOI2006] 公路修建问题

Problem E

欧拉回路——邮递员

新年好

潭拓寺