HDU 1069 dp最长递增子序列

Posted Arlenmbx

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1069 dp最长递增子序列相关的知识,希望对你有一定的参考价值。

B - Monkey and Banana
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description:

Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn‘t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input

1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output

Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 
 
每个格子可以形成6种状态,最多有180种状态,,,,,,,对X,Y作为判断条件进行判断,累加Z值
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct node{
    int x,y,z;
}que[200];
int dp[200];
int tot;

void addedge(int x,int y,int z){
     que[tot].x=x;
     que[tot].y=y;
     que[tot++].z=z;

      que[tot].x=x;
     que[tot].y=z;
     que[tot++].z=y; 
     
     que[tot].x=y;
     que[tot].y=x;
     que[tot++].z=z;
    
     que[tot].x=y;
     que[tot].y=z;
     que[tot++].z=x;
    
     que[tot].x=z;
     que[tot].y=x;
     que[tot++].z=y; 
     
     que[tot].x=z;
     que[tot].y=y;
     que[tot++].z=x;
}

bool cmp(struct node t1,struct node t2){
     if(t1.x!=t2.x)
         return t1.x>t2.x;
     else if(t1.x==t2.x&&t1.y!=t2.y)
         return t1.y>t2.y;
     else
         return t1.z>t2.z;
}

int main(){
   int n;
   int cas=1;
   while(scanf("%d",&n)!=EOF){
       if(!n)
           break;
       memset(dp,0,sizeof(dp));
        tot=1;
       int x,y,z;
       for(int i=0;i<n;i++){
           scanf("%d%d%d",&x,&y,&z);
           addedge(x,y,z);
       }
       sort(que+1,que+tot+1,cmp);
       dp[1]=que[1].z;
       for(int i=2;i<tot;i++){
           dp[i]=que[i].z;
          for(int j=i-1;j>=1;j--){
              if(que[i].x<que[j].x&&que[i].y<que[j].y&&dp[i]<dp[j]+que[i].z)
                  dp[i]=dp[j]+que[i].z;
          }
       }
       int ans=-1;
       for(int i=1;i<tot;i++)
           ans=max(ans,dp[i]);
        printf("Case %d: maximum height = %d\n",cas++,ans);
   }
   return 0;
}

 

 

以上是关于HDU 1069 dp最长递增子序列的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1069 Monkey and Banana(DP——最大递减子序列)

LeetCode刷题 最长递增子序列

dp的二分优化NO300 最长递增子序列

Bridging signals POJ 1631(最长递增子序列dp)

hdu1159Common Subsequence(DP最长公共递增序列)

DP简单问题联系--最长递增子序列+最长公共子序列等