CSU - 1828 康托展开

Posted 西北会法语

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了CSU - 1828 康托展开相关的知识,希望对你有一定的参考价值。

The isolated people of MacGuffin Island have a unique culture, and one of the most interesting things about them is their language. Their alphabet consists of the first 9 letters of the Roman alphabet (a, b, c, d, e, f, g, h, i). All of their words are exactly 9 letters long and use each of these 9 letters exactly once. They have a word for every possible permutation of these letters. In the library of their most sacred temple is a dictionary, and each word in their language has its own page. By coincidence they order their words exactly as they would be in ordered in English, so the word ‘abcdefghi’ is on the first page, and the word ‘ihgfedcba’ is on the last. The question is, given a list of random words from the MacGuffin language, can you say on which page of the MacGuffin dictionary each appears?

Input

The first line of the input file is a positive integer. This integer tells you how many words will follow. The upper limit for this number is 6000. Every subsequent line contains a single word from the MacGuffin language, so if the first number is 1000 there will be 1000 lines after it, each containing a single word.

Output

Each line of output will contain an integer. This integer should be the page number for the corresponding word.

Sample Input

4
abcdefgih
abcdefghi
abcdefgih
ihgfedcba

Sample Output

2
1
2
362880


#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

char c[15];
int jie[15];

void jiec() {
jie[1]=1;
for(int i=2;i<=9;i++)
jie[i]=jie[i-1]*i;
}

int cantor(char* c) {
int cnt=0,ret=0;
for(int i=0;i<9;i++)
{
cnt=0;
for(int j=i+1;j<9;j++)
if(c[i]>c[j])
cnt++;
ret+=cnt*jie[8-i];
}
return ret;
}

int main() {
int T;
scanf("%d",&T);
jiec();
while(T--)
{
scanf("%s",c);
printf("%d\n",cantor(c)+1);
}

return 0;
}

以上是关于CSU - 1828 康托展开的主要内容,如果未能解决你的问题,请参考以下文章

宽搜经典题之二——8数码难题+康托展开

全排列的编码与解码——康托展开 (附完整代码)

康托展开 / 逆康托展开

康托展开 & 逆康托展开

康托展开小结-

LG5367 「模板」康托展开 康托展开