1064. Complete Binary Search Tree (30)二叉树——PAT (Advanced Level) Practise

Posted liguangsunls

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1064. Complete Binary Search Tree (30)二叉树——PAT (Advanced Level) Practise相关的知识,希望对你有一定的参考价值。

题目信息

1064. Complete Binary Search Tree (30)

时间限制100 ms
内存限制65536 kB
代码长度限制16000 B

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4

解题思路

模拟建树推出层序

AC代码

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
int n, a[1005];
vector<int> level[22];
void step(int loc, int len, int lv){
  if (len <= 0) return;
  int t = 1;
  while (t*2 <= len) t *= 2;
  --t;
  int cd = ((len - (len - t)) + 1) / 2 + len - t;

  if (cd <= t + 1){
    level[lv].push_back(a[loc + cd - 1]);
    step(loc, cd - 1, lv + 1);
    step(loc + cd, len - cd, lv + 1);
  }else{
    level[lv].push_back(a[loc + t]);
    step(loc, t, lv + 1);
    step(loc + t + 1, len - t - 1, lv + 1);
  }
}
int main()
{
  scanf("%d", &n);
  for (int i = 0; i < n; ++i){
    scanf("%d", a+i);
  }
  sort(a, a + n);
  step(0, n, 0);
  printf("%d", level[0][0]);
  for (int i = 1; i <= 13; ++i){
    for (int j = 0; j < level[i].size(); ++j){
      printf(" %d", level[i][j]);
    }
  }
  printf("\n");
}

个人游戏推广:
android.myapp.com/myapp/detail.htm?

apkName=com.xianyun.yf" target="_blank" align="left">技术分享《10云方》与方块来次消除大战!








以上是关于1064. Complete Binary Search Tree (30)二叉树——PAT (Advanced Level) Practise的主要内容,如果未能解决你的问题,请参考以下文章

PAT 1064 Complete Binary Search Tree[二叉树][难]

1064 Complete Binary Search Tree (30 分)完全二叉树

PAT_A1064 Complete Binary Search Tree

PAT Advanced 1064 Complete Binary Search Tree (30分)

PAT Advanced Level 1064 Complete Binary Search Tree (30)(30 分)

1064. Complete Binary Search Tree (30)二叉树——PAT (Advanced Level) Practise