PAT Advanced 1064 Complete Binary Search Tree (30分)

Posted littlepage

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT Advanced 1064 Complete Binary Search Tree (30分)相关的知识,希望对你有一定的参考价值。

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node‘s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node‘s key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0
 

Sample Output:

6 3 8 1 5 7 9 0 2 4

已知一组数据,我们需要进行构成满二叉排序树,并且打印层序遍历。

我们可以进行sort一下,就是中序遍历,然后进行中序遍历插入数据即可。

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int N, index_v = 0 ;
vector<int> v, res;
void inorder(int index_res){
    if(index_res >= N) return ;
    inorder(2 * index_res + 1);
    res[index_res] = v[index_v++];
    inorder(2 * index_res + 2);
}
int main(){
    cin >> N;
    v.resize(N);
    res.resize(N);
    for(int i = 0; i < N; i++)
        cin >> v[i];
    sort(v.begin(),v.end());
    inorder(0);
    cout << res[0];
    for(int i = 1; i < N; i++)
        cout << " " << res[i];
    system("pause");
    return 0;
}

 

以上是关于PAT Advanced 1064 Complete Binary Search Tree (30分)的主要内容,如果未能解决你的问题,请参考以下文章

1064. Complete Binary Search Tree (30)二叉树——PAT (Advanced Level) Practise

PAT (Advanced Level) 1064. Complete Binary Search Tree (30)

PAT (Advanced Level) 1025. PAT Ranking (25)

1093. Count PAT's (25)计数——PAT (Advanced Level) Practise

PAT甲级1064

PAT (Advanced Level) 1025 PAT Ranking