PAT_A1064 Complete Binary Search Tree

Posted jacobfun

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT_A1064 Complete Binary Search Tree相关的知识,希望对你有一定的参考价值。

Complete Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node‘s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node‘s key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4
这道题如果不清楚一个知识点的话就很难做,一开始我一直在判断到底什么时候最后一排没满,到底要加多少,但是,其实,如果你了解完全二叉树性质的话,这道题就能迎刃而解:
完全二叉树的叶可以不满,其他都要求要满。
若完全二叉树任何一个节点序号为x(从1开始)那么,该节点的左子节点的序号为2x,右子节点的序号为2x+1。这样我们可以通过递归
(中序排列顺序)每个节点的左右子节点(退出条件为序号是否超过n),然后我们很容易得到,每个被递归(中序排列顺序)的节点的值和排完序的数组的关系:
那就是排序二叉树的中序遍历是按照顺序递增的,递归第一次结束进行赋值是把排完序的数组第一个(最小值)赋值,紧接着第二个赋值第二小的(你也可以仔细想一想完全二叉树的从小到大的顺序在树上是怎么样的,以及递归(中序排列)为什么能够解决。
AC代码:
#include <stdio.h>
#include <algorithm>
using namespace std;
struct tree
	int num;
	tree* left;
	tree* right;
;
int ans[1010];
int a[1010];
int t, n;
void binary(int i)

	if(i > n) 
		return ;
	binary(2 * i);
	ans[i] = a[t++];
	binary(2 * i + 1);
;
int main(void)

	scanf("%d", &n);
	for(int i = 0; i < n; i++)
	
		scanf("%d", &a[i]);
	
	sort(a, a + n);
	binary(1);
	for(int i = 1; i <= n; i++)
	
		printf("%d", ans[i]);
		if(i < n)
			printf(" ");
	
	return 0;

  

感谢自:https://blog.csdn.net/hy971216/article/details/81838750的题解报告


以上是关于PAT_A1064 Complete Binary Search Tree的主要内容,如果未能解决你的问题,请参考以下文章

PAT 1064. Complete Binary Search Tree

PAT 1064 Complete Binary Search Tree[二叉树][难]

1064 Complete Binary Search Tree (30 分)完全二叉树

PAT Advanced 1064 Complete Binary Search Tree (30分)

PAT Advanced Level 1064 Complete Binary Search Tree (30)(30 分)

1064. Complete Binary Search Tree (30)二叉树——PAT (Advanced Level) Practise