http://acm.hdu.edu.cn/showproblem.php?pid=4950MonsterTimeLimit:2000/1000MS(Java/Others)    MemoryLimit:65536/65536K(Jav"/>

hdu 4950 Monster(数学题,多校8)

Posted brucemengbm

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 4950 Monster(数学题,多校8)相关的知识,希望对你有一定的参考价值。

题目链接:php?

pid=4950http://acm.hdu.edu.cn/showproblem.php?pid=4950">http://acm.hdu.edu.cn/showproblem.php?pid=4950


Monster

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 220    Accepted Submission(s): 92


Problem Description
Teacher Mai has a kingdom. A monster has invaded this kingdom, and Teacher Mai wants to kill it.

Monster initially has h HP. And it will die if HP is less than 1.

Teacher Mai and monster take turns to do their action. In one round, Teacher Mai can attack the monster so that the HP of the monster will be reduced by a. At the end of this round, the HP of monster will be increased by b.

After k consecutive round‘s attack, Teacher Mai must take a rest in this round. However, he can also choose to take a rest in any round.

Output "YES" if Teacher Mai can kill this monster, else output "NO".
 
Input
There are multiple test cases, terminated by a line "0 0 0 0".

For each test case, the first line contains four integers h,a,b,k(1<=h,a,b,k <=10^9).
 
Output
For each case, output "Case #k: " first, where k is the case number counting from 1. Then output "YES" if Teacher Mai can kill this monster, else output "NO".
 
Sample Input
5 3 2 2 0 0 0 0
 
Sample Output
Case #1: NO
 
Source

题意:给出怪兽的血量h,玩家每回合造成的伤害a,每一回合结束后怪兽会回血量b,玩家在连续攻击k回合后须歇息一次(也能够在K回合之前的随意回合歇息)。推断玩家是否能杀死怪兽!



思路:贪心。必定是打了K回合后再歇息!详细见代码解析;

技术分享


代码例如以下:

#include<cstdio>
typedef __int64 LL;
int main()
{
    LL h,a,b,k;
    LL cas = 0;
    while(~scanf("%I64d%I64d%I64d%I64d",&h,&a,&b,&k))
    {
        if(h==0 && a==0 && b==0 && k==0)
            break;
        printf("Case #%I64d: ",++cas);
        if(h <= a)//第一回合怪兽就死亡
        {
            printf("YES\n");
            continue;
        }
        if((k-1)*(-a+b)-a+h <= 0)//前K回合怪兽死亡
        {
            printf("YES\n");
            continue;
        }
        if(k*(-a+b)+b < 0)//每K回合后怪兽的血量在降低
        {
            printf("YES\n");
            continue;
        }
        printf("NO\n");
    }
    return 0;
}


技术分享


























以上是关于hdu 4950 Monster(数学题,多校8)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 4950 Monster (贪心算法)

HDU 6050 17多校2 Funny Function(数学+乘法逆元)

HDU6038-Function-数学+思维-2017多校Team01

2017多校第一套&&hdu6038 思维 数学

HDU多校赛第9场 HDU 4965Fast Matrix Calculation矩阵运算+数学小知识

2021牛客多校6 - Gambling Monster(分治FWT优化期望dp)