Legal or Not

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Legal or Not相关的知识,希望对你有一定的参考价值。

            Legal or Not

      Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
        Total Submission(s): 3151    Accepted Submission(s): 1432


  Problem Description

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it‘s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian‘s master and, at the same time, 3xian is HH‘s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B‘s master ans B is C‘s master, then A is C‘s master.
 

 

  Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y‘s master and y is x‘s prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

 

  Output

For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

 

  Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output

YES
NO
 

题目大意:

在一个群里面,大家互相请教问题,比如A请教B,我们就把B叫做师傅,把A叫做徒弟,这样会产生很多“师傅——徒弟”的关系,一个徒弟可以有很多的师傅,一个师傅也可以有很多徒弟,这是合法的,但是不能出现A是B的师傅而且B是A的师傅,或者A是B的徒弟而且B是A的徒弟,或者在一个更大的关系环里面出现这种情况。

思路:

很明显题目的意思就是,判断一个给定的有向图中是否存在环。了解了这些,解题方法就非常简单了,那就是直接进行拓扑排序即可,统计拓扑排序完成之时能记录的度为0的节点的个数,若个数等于节点个数则说明无环,否则是有环的。

注意·:

该题为输入多组数据,所以我们每一次进行询问和查询的时候都要将所有的数组以及sum,tot等记录的值清空。

代码:

#include<queue>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#define N 1000
using namespace std;
int n,m,a,b,x,sum,tot;
int head[N],in[N];
queue<int>q;
struct Edge
{
    int from,to,next;
}edge[N];
void add(int x,int y)
{
    tot++;
    edge[tot].to=y;
    edge[tot].next=head[x];
    head[x]=tot;
}
int main()
{
    while(scanf("%d%d",&n,&m))
    {
        while(!q.empty()) q.pop();
        tot=0,sum=0;
        memset(in,0,sizeof(in));
        memset(head,0,sizeof(head));
        if(n==0) return 0;
        for(int i=1;i<=m;i++)
         scanf("%d%d",&a,&b),add(a,b),in[b]++;
        for(int i=0;i<n;i++)
          if(in[i]==0) q.push(i);
        while(!q.empty())
        {
            x=q.front();q.pop();sum++;
            for(int i=head[x];i;i=edge[i].next)
            {
                in[edge[i].to]--;
                if(in[edge[i].to]==0) 
                  q.push(edge[i].to);
            }
        }
        if(sum!=n) printf("NO\n");
        else printf("YES\n");
    }
}

 

以上是关于Legal or Not的主要内容,如果未能解决你的问题,请参考以下文章

HDU 3342 Legal or Not(拓扑排序判断成环)

Legal or Not

legal or not

Legal or Not

Legal or Not ,图的拓扑

hdu 3342 Legal or Not