legal or not

Posted 小时のblog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了legal or not相关的知识,希望对你有一定的参考价值。

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8325    Accepted Submission(s): 3918


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it‘s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian‘s master and, at the same time, 3xian is HH‘s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B‘s master ans B is C‘s master, then A is C‘s master.
 

 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y‘s master and y is x‘s prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

 

Sample Input
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 

 

Sample Output
YES NO
 

 

Author
 

 

Source
 

 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1285 2647 3333 3339 3341 
 
【思路】拓扑排序判断环
【code】
#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<vector>
using namespace std;
queue<int>q;
vector<int>vec[101];
int n,m,cnt,r[101];
int main()
{
    while(scanf("%d%d",&n,&m)&&n&&m)
    {
        cnt=0;
        while(!q.empty())q.pop();
        for(int i=0;i<n;i++)
        vec[i].clear();
        memset(r,0,sizeof(r));
        for(int i=1;i<=m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            vec[x].push_back(y);
            r[y]++;
        }
        for(int i=0;i<n;i++)
        {
            if(!r[i])
            q.push(i); 
        }
        while(!q.empty())
        {
            int now=q.front();q.pop();
            cnt++;
            for(int i=0;i<vec[now].size();i++)
            {
                r[vec[now][i]]--;
                if(!r[vec[now][i]])
                q.push(vec[now][i]); 
            }
        }
        if(cnt!=n)printf("NO\n");
        else printf("YES\n");
    }
    return 0;
 } 

 

以上是关于legal or not的主要内容,如果未能解决你的问题,请参考以下文章

HDU 3342 Legal or Not(拓扑排序判断成环)

Legal or Not

legal or not

Legal or Not

Legal or Not ,图的拓扑

hdu 3342 Legal or Not