根据后序和中序遍历输出先序遍历
Posted cuitiaotiao
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了根据后序和中序遍历输出先序遍历相关的知识,希望对你有一定的参考价值。
本题要求根据给定的一棵二叉树的后序遍历和中序遍历结果,输出该树的先序遍历结果。
输入格式:
第一行给出正整数N(≤30),是树中结点的个数。随后两行,每行给出N个整数,分别对应后序遍历和中序遍历结果,数字间以空格分隔。题目保证输入正确对应一棵二叉树。
输出格式:
在一行中输出Preorder:
以及该树的先序遍历结果。数字间有1个空格,行末不得有多余空格。
输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
Preorder: 4 1 3 2 6 5 7
之前学递归,全排列、整数分解什么的都做不出来,也不想想,弄的自己原地停了一个星期。。。。现在想想,还是自己太着急。
这个题用递归实现的,知道中序遍历和后序遍历,建树,然后输出先序遍历。递归思路和创建树一样,就是创建根节点,创建它的左孩子右孩子,多了参数限制
#include<iostream>
#include<stdio.h>
#include<stdlib.h>
using namespace std;
typedef int TElemType;
typedef int Status;
using namespace std;
typedef int TElemType;
typedef int Status;
#define OK 1
#define ERROR 0
#define ERROR 0
typedef struct BiTNode
{
TElemType data;
struct BiTNode *lchild,*rchild;
} BiTNode,*BiTree;
{
TElemType data;
struct BiTNode *lchild,*rchild;
} BiTNode,*BiTree;
BiTree CreateTreeByPreAndIn(TElemType *pos,TElemType *in,int len)//归纳:找到根(为数组pos的最后一个元素),创建节点,赋给它,
//也就是创建跟节点。然后递归创建左子树,右子树,注意左子树和右子树的范围。递归边界为:数组长小于等于0
{
if(len <= 0)
return NULL;
//也就是创建跟节点。然后递归创建左子树,右子树,注意左子树和右子树的范围。递归边界为:数组长小于等于0
{
if(len <= 0)
return NULL;
BiTNode* T;//分配空间了吗
T = new BiTNode;//!!!!!!!!!!!!!!!!
T -> data = *(pos + len - 1);//后序遍历的最后一个为根节点;
int rool = 0;//从1开始算
for(int i = 1;i <= len;++i)
{
rool++;
if(*(pos + len - 1) == *(in + i - 1))
break;
//p++;
}//找到在中序中rool的位置
int length = rool-1;//左子树长度
T -> lchild = CreateTreeByPreAndIn(pos,in,length);
T -> rchild = CreateTreeByPreAndIn(pos + length,in + length + 1,len - length - 1);
T = new BiTNode;//!!!!!!!!!!!!!!!!
T -> data = *(pos + len - 1);//后序遍历的最后一个为根节点;
int rool = 0;//从1开始算
for(int i = 1;i <= len;++i)
{
rool++;
if(*(pos + len - 1) == *(in + i - 1))
break;
//p++;
}//找到在中序中rool的位置
int length = rool-1;//左子树长度
T -> lchild = CreateTreeByPreAndIn(pos,in,length);
T -> rchild = CreateTreeByPreAndIn(pos + length,in + length + 1,len - length - 1);
return T;
}
}
Status PreOrderPrint(BiTree T)
{
if(T == NULL) return OK;
printf(" %d",T -> data);//前面带空格
PreOrderPrint(T -> lchild);
PreOrderPrint(T -> rchild);
return OK;
}
{
if(T == NULL) return OK;
printf(" %d",T -> data);//前面带空格
PreOrderPrint(T -> lchild);
PreOrderPrint(T -> rchild);
return OK;
}
int main()
{
int len;int *pos;int *in;
cin>>len;
pos = (int *)malloc(len * sizeof(int));
in = (int *)malloc(len * sizeof(int));
for(int i = 1;i <= len;++i)
cin>>*(pos + i - 1);
for(int j = 1;j <= len;++j)
cin>>in[j-1];
BiTree T;
T = CreateTreeByPreAndIn(pos,in,len);
cout<<"Preorder:";
PreOrderPrint(T);
{
int len;int *pos;int *in;
cin>>len;
pos = (int *)malloc(len * sizeof(int));
in = (int *)malloc(len * sizeof(int));
for(int i = 1;i <= len;++i)
cin>>*(pos + i - 1);
for(int j = 1;j <= len;++j)
cin>>in[j-1];
BiTree T;
T = CreateTreeByPreAndIn(pos,in,len);
cout<<"Preorder:";
PreOrderPrint(T);
}
以上是关于根据后序和中序遍历输出先序遍历的主要内容,如果未能解决你的问题,请参考以下文章
数据结构树 —— 编程作业 04 :根据后序和中序遍历输出先序遍历