poj3273 二分
Posted 当蜗牛有了理想
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj3273 二分相关的知识,希望对你有一定的参考价值。
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 21448 | Accepted: 8429 |
Description
Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.
FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.
FJ‘s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.
Input
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Sample Input
7 5 100 400 300 100 500 101 400
Sample Output
500
Hint
Source
#include<algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
using namespace std;
const int maxn=100000+100;
int a[maxn];
int n,k;
bool check(__int64 x)
{
int t=0;
__int64 sum=0;
for(int i=0;i<n;i++)
{
sum+=a[i];
if(sum>x)
{
sum=a[i];
t++;
}
}
if(t+1>k) return false;
else return true;
}
int main()
{
while(~scanf("%d%d",&n,&k))
{
__int64 sum=0;
int ma=0;
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
if(ma<a[i])ma=a[i];
sum+=a[i];
}
__int64 l=ma,r=sum;
__int64 ans;
while(l<=r)
{
__int64 mid=(l+r)>>1;
if(check(mid)) ans=mid,r=mid-1;
else l=mid+1;
}
printf("%d\n",ans);
}
return 0;
}
以上是关于poj3273 二分的主要内容,如果未能解决你的问题,请参考以下文章
Monthly Expense POJ - 3273 (最大值最小化)(二分答案)