POJ 2140 Herd Sums

Posted Not-Bad

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 2140 Herd Sums相关的知识,希望对你有一定的参考价值。

http://poj.org/problem?id=2140

Description

The cows in farmer John‘s herd are numbered and branded with consecutive integers from 1 to N (1 <= N <= 10,000,000).  When the cows come to the barn for milking, they always come in sequential order from 1 to N.
Farmer John, who majored in mathematics in college and loves numbers, often looks for patterns.  He has noticed that when he has exactly 15 cows in his herd, there are precisely four ways that the numbers on any set of one or more consecutive cows can add up to 15 (the same as the total number of cows).  They are: 15, 7+8, 4+5+6, and 1+2+3+4+5.
When the number of cows in the herd is 10, the number of ways he can sum consecutive cows and get 10 drops to 2: namely 1+2+3+4 and 10.
Write a program that will compute the number of ways farmer John can sum the numbers on consecutive cows to equal N.  Do not use precomputation to solve this problem.

Input

* Line 1: A single integer: N

Output

* Line 1: A single integer that is the number of ways consecutive cow brands can sum to N.

Sample Input

15

Sample Output

  4

ps:consecutive  连续地

 

 

水题.....一次过

//{头文件
#include <algorithm>
#include <bitset>
#include <cassert>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <functional>
#include <iomanip>
#include <iostream>
#include <list>
#include <map>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>
using namespace std;
//}头文件

double N;

bool f(int n)        //n为几个数组相连
{
    double n0 = n,k = N / n0;
    int t = k;
    if( n%2 ){
        if(t == k){
            if(t - n/2 > 0)return true;
        }
    }
    else {
        if( t * n + n/2 == N){
            if(t + 1 - n/2 >0)return true;
        }
    }
    return false;
}

int main() 
{
    cin >> N;
    int T = 1;
    for(int i = 2; i < N/2;i++){
        if(f(i))T++;
    }
    cout << T <<endl;
    //system("pause");
    return 0;
}

 

以上是关于POJ 2140 Herd Sums的主要内容,如果未能解决你的问题,请参考以下文章

poj 2140 Herd Sums(等差数列)

POJ 2140 Herd Sums 公式推导

POJ3187 Backward Digit Sums

POJ2602 Superlong sums水题

poj2140(奇因数的个数)

Backward Digit Sums POJ - 3187