POJ2602 Superlong sums水题

Posted tigerisland45

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ2602 Superlong sums水题相关的知识,希望对你有一定的参考价值。

Superlong sums
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 23914 Accepted: 7086

Description

The creators of a new programming language D++ have found out that whatever limit for SuperLongInt type they make, sometimes programmers need to operate even larger numbers. A limit of 1000 digits is so small... You have to find the sum of two numbers with maximal size of 1.000.000 digits.

Input

The first line of an input file contains a single number N (1<=N<=1000000) - the length of the integers (in order to make their lengths equal, some leading zeroes can be added). It is followed by these integers written in columns. That is, the next N lines contain two digits each, divided by a space. Each of the two given integers is not less than 1, and the length of their sum does not exceed N.

Output

Output file should contain exactly N digits in a single line representing the sum of these two integers.

Sample Input

4
0 4
4 2
6 8
3 7

Sample Output

4750
Hint

Huge input,scanf is recommended.

Source

Ural State University collegiate programming contest 2000

问题链接POJ2602 Superlong sums
问题简述:(略)
问题分析
????大数计算的水题,要看程序是否写得简洁。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C语言程序如下:

/* POJ2602 Superlong sums */

#include <stdio.h>

#define N 1000000
char a[N + 1];

int main(void)
{
    int n, b, carry, i;
    scanf("%d", &n);
    for(i = 0; i < n; i++) {
        scanf("%d%d", &a[i], &b);
        a[i] += b;
    }
    for(carry = 0, i--; i >= 0; i--) {
        a[i] += carry;
        carry = a[i] / 10;
        a[i] %= 10;
        a[i] += '0';
    }

    puts(a);

    return 0;
}

以上是关于POJ2602 Superlong sums水题的主要内容,如果未能解决你的问题,请参考以下文章

水题-poj1979

poj3421 X-factor Chains——分解质因数

POJ 2365YY水题

poj 3041 (水题)

求poj基础水题!

POJ1747 Expression水题