P2884 [USACO07MAR]每月的费用Monthly Expense

Posted song-

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了P2884 [USACO07MAR]每月的费用Monthly Expense相关的知识,希望对你有一定的参考价值。

题目描述

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ‘s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

给出农夫在n天中每天的花费,要求把这n天分作m组,每组的天数必然是连续的,要求分得各组的花费之和应该尽可能地小,最后输出各组花费之和中的最大值

输入输出格式

输入格式:

 

Line 1: Two space-separated integers: N and M

Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

 

输出格式:

 

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

 

输入输出样例

输入样例#1: 复制
7 5
100
400
300
100
500
101
400
输出样例#1: 复制
500

二分查找:
技术分享图片
#include<cstdio>
 
#define max(a,b) (a>b?a:b) 
 
using namespace std;
int n,m[100009],k,l=0,r,mid,sum,maxx=-1;
bool judge(int x){
    int ans=1,f=0;
    for(int i=1;i<=n;i++)
    {
        f+=m[i];
        if(f==x) ans++,f=0;
        if(f>x){
            ans++;f=0;f+=m[i];
        }
    }if(ans<=k&&x>=maxx) return true;
    else return false;
}
 
int main()
{
    scanf("%d%d",&n,&k);
    for(int i=1;i<=n;++i){
        scanf("%d",&m[i]);
        sum+=m[i];maxx=max(maxx,m[i]);
    }
    r=sum;
    while(l<=r){
        mid=(l+r)/2;
        if(judge(mid)==1) r=mid-1;
        else l=mid+1;
    }printf("%d",l);
    return 0;
}
View Code

说明

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most$500 in any month. Any other method of scheduling gives a larger minimum monthly limit.



以上是关于P2884 [USACO07MAR]每月的费用Monthly Expense的主要内容,如果未能解决你的问题,请参考以下文章

BZOJ1680: [Usaco2005 Mar]Yogurt factory

BZOJ1597: [Usaco2008 Mar]土地购买

[USACO14MAR]浇地Watering the Fields

COGS [USACO Mar07] 奶牛交通

POJ3275 [USACO07MAR]Ranking the Cows

[USACO08MAR]土地征用Land Acquisition