CF802G Fake News (easy)

Posted 一蓑烟雨任生平

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了CF802G Fake News (easy)相关的知识,希望对你有一定的参考价值。

题意翻译

给定一个字符串询问能否听过删除一些字母使其变为“heidi”

如果可以输出“YES”,不然为“NO”

题目描述

As it\'s the first of April, Heidi is suspecting that the news she reads today are fake, and she does not want to look silly in front of all the contestants. She knows that a newspiece is fake if it contains heidi as a subsequence. Help Heidi assess whether the given piece is true, but please be discreet about it...

输入输出格式

输入格式:

 

The first and only line of input contains a single nonempty string ss of length at most 10001000 composed of lowercase letters (a-z).

 

输出格式:

 

Output YES if the string ss contains heidi as a subsequence and NO otherwise.

 

输入输出样例

输入样例#1: 复制
abcheaibcdi
输出样例#1: 复制
YES
输入样例#2: 复制
hiedi
输出样例#2: 复制
NO

说明

A string ss contains another string pp as a subsequence if it is possible to delete some characters from ss and obtain pp .

#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
char ch[1100];
queue<char> que;
int main() {
    que.push(\'h\');que.push(\'e\');que.push(\'i\');
    que.push(\'d\');que.push(\'i\');cin>>ch;
    int len=strlen(ch);
    for(int i=0;i<len;i++)
        if(!que.empty())
            if(ch[i]==que.front())
                que.pop();
    if(que.empty())    cout<<"YES";
    else    cout<<"NO";
}

 

 

以上是关于CF802G Fake News (easy)的主要内容,如果未能解决你的问题,请参考以下文章

NSSCTF逆向2023题目《doublegame》《fake_game》《easy_pyc》《For Aiur》

Fake Xrm Easy:如何在 orgService.Create() 上模拟插件的行为?

[CF804F]Fake bullions

谣言检测论文精读——11.SAFE: Similarity-Aware Multi-Modal Fake News Detection

16.6 假新闻识别 Fake News Detection on Social Media A Data Mining Perspective

CF1096D Easy Problem [dp]