HDU_1087_Super Jumping! Jumping! Jumping!_dp

Posted Jason333

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU_1087_Super Jumping! Jumping! Jumping!_dp相关的知识,希望对你有一定的参考价值。

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32179    Accepted Submission(s): 14487


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

 

Output
For each case, print the maximum according to rules, and one line one case.
 

 

Sample Input
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

 

Sample Output
4 10 3
 
简单dp。
 
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

int num[1005];
int dp[1005];

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
        int ans=0;
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
            scanf("%d",&num[i]);
        for(int i=1; i<=n; i++)
            for(int j=0; j<i; j++)
                {if(num[i]>num[j])
                    dp[i]=max(dp[i],dp[j]+num[i]);
                    if(ans<dp[i])
                        ans=dp[i];
                    }
        printf("%d\\n",ans);
    }
    return 0;
}
View Code

 

以上是关于HDU_1087_Super Jumping! Jumping! Jumping!_dp的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1087 Super Jumping! Jumping! Jumping

[2016-03-27][HDU][1087][Super Jumping! Jumping! Jumping!]

HDU 1087 Super Jumping! Jumping! Jumping! (DP+LIS)

HDu1087 Super Jumping! Jumping! Jumping!

HDU-1087.Super Jumping! Jumping! Jumping!

Super Jumping! Jumping! Jumping! HDU 1087