POJ 2478Farey Sequence

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 2478Farey Sequence相关的知识,希望对你有一定的参考价值。

???????????????   limit   ever   turn   miss   eve   ace   std   accept   

Farey Sequence
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 17744   Accepted: 7109

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

Source

 
 
std????????????????????????
???n??????ans[n]?????????$ans[n]=ans[n-1]+phi[n]$,???n????????????????????????10???6???????????????????????????????????? 
??????????????????i??????????????????$md[i]$??????????????????????????????????????????3?????????$phi[i]$
????????????????????????????????????
 
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#define LL long long 
using namespace std;
const LL MAXN=3*1e6+10;
LL prime[MAXN],tot=0,vis[MAXN],phi[MAXN],N;
void GetPhi()
{
    for(LL i=2;i<=N;i++)
    {
        if(!vis[i])
        {
            prime[++tot]=i;
            phi[i]=i-1;
        }
        for(LL j=1;j<=tot&&prime[j]*i<=N;j++)
        {
            vis[ i*prime[j] ] = 1; 
            if(i%prime[j]==0)
            {
                phi[ i*prime[j] ]=phi[i]*prime[j];
                break;
            }
            else phi[ i*prime[j] ]=phi[i]*(prime[j]-1);
        }
    }
    for(LL i=1;i<=N;i++)
        phi[i]=phi[i]+phi[i-1];
}
int main()
{
    N=2*1e6+10;
    GetPhi();
    while(cin>>N&&N!=0)
        printf("%lld\n",phi[N]);
    return 0;
}

 

以上是关于POJ 2478Farey Sequence的主要内容,如果未能解决你的问题,请参考以下文章

poj-2478 Farey Sequence(dp,欧拉函数)

POJ 2478Farey Sequence

Farey Sequence POJ - 2478 (欧拉函数 前缀和)

POJ 2478 Farey Sequence(欧拉函数前n项和)

欧拉函数表POJ2478-Farey Sequence

poj2478-Farey Sequence递推求欧拉函数-欧拉函数的几个性质和推论