POJ 3253 Fence Repair

Posted Anthony_azy

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 3253 Fence Repair相关的知识,希望对你有一定的参考价值。

Fence Repair
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 37102   Accepted: 12015

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn‘t own a saw with which to cut the wood, so he mosies over to Farmer Don‘s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn‘t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).


题意:将一块很长的木板切割成N块,每次切断木板时,需要的开销为这块木板的长度,求切割完最小的开销是多少

分析:

切割的方法类似二叉树,这里的每一个叶子节点就对应了切割出的一块块木板。叶子节点的深度就对应了为了得到木板所需的切割次数,开销的合集就是各叶子节点的

木板的长度 * 节点的深度

的总和

此时的最佳切割方法首先应该具有如下性质:

最短的板与次短的板的节点应当是兄弟节点。

不妨将L1按照大小顺序排列,那么最短的板应该是L1而次短的板则是L2.如果他们是兄弟节点,就意味着他们是从一块长度为(L1+L2)的板切割得来的。由于切割顺序是自由的,不放当作是最后被切割。这样一来,在这次切割前就有

(L1 + L2),L3,L4,...Ln

这样的n - 1块木板存在。与以上讨论的方式相同,递归的将这N—1块木板的问题求解,就可以求得答案。

#include <cstdio>
#include <algorithm>
using namespace std;

typedef long long ll;

int n, l[20001];
void solve()
{
    ll ans = 0;
    while (n > 1){   //直到计算到木板为1块时为止
        int m1 = 0, m2 = 1;
        if (l[m1] > l[m2])    //求出最短的板m1和次短的板m2
            swap(m1, m2);
        for (int i = 2; i < n; i++){
            if (l[i] < l[m1]){
                m2 = m1;
                m1 = i;
            }
            else if (l[i] < l[m2])
                m2 = i;
        }
        //将两块板拼合
        int t = l[m1] + l[m2];
        ans += t;
        if (m1 == n - 1)
            swap(m1, m2);
        l[m1] = t;
        l[m2] = l[n - 1];
        n--;
    }
    printf("%lld\n", ans);
}

int main()
{
    scanf("%d", &n);
    for (int i = 0; i < n; i++)
        scanf("%d", &l[i]);
    solve();
    return 0;
}



以上是关于POJ 3253 Fence Repair的主要内容,如果未能解决你的问题,请参考以下文章

poj 3253 Fence Repair 优先队列

poj 3253 Fence Repair 贪心

POJ 3253 Fence Repair

[POJ3253] Fence Repair

POJ 3253——Fence Repair

POJ 3253 Fence Repair