洛谷 P3146 [USACO16OPEN]248

Posted 一蓑烟雨任生平

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了洛谷 P3146 [USACO16OPEN]248相关的知识,希望对你有一定的参考价值。

题目描述

Bessie likes downloading games to play on her cell phone, even though she doesfind the small touch screen rather cumbersome to use with her large hooves.

She is particularly intrigued by the current game she is playing.The game starts with a sequence of NN positive integers (2 \leq N\leq 2482N248), each in the range 1 \ldots 40140. In one move, Bessie cantake two adjacent numbers with equal values and replace them a singlenumber of value one greater (e.g., she might replace two adjacent 7swith an 8). The goal is to maximize the value of the largest numberpresent in the sequence at the end of the game. Please help Bessiescore as highly as possible!

给定一个1*n的地图,在里面玩2048,每次可以合并相邻两个,问最大能合出多少

输入输出格式

输入格式:

 

The first line of input contains NN, and the next NN lines give the sequence

of NN numbers at the start of the game.

 

输出格式:

 

Please output the largest integer Bessie can generate.

 

输入输出样例

输入样例#1:
4
1
1
1
2
输出样例#1:
3

说明

In this example shown here, Bessie first merges the second and third 1s to

obtain the sequence 1 2 2, and then she merges the 2s into a 3. Note that it is

not optimal to join the first two 1s.

思路:区间DP。f[i][j]表示区间i-j之间的最大值。

吐槽:加强版戳这里

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAXN 300 
using namespace std;
int n,ans;
int f[MAXN][MAXN];
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d",&f[i][i]);
        ans=max(ans,f[i][i]);
    }
    for(int i=n-1;i>=1;i--)
        for(int j=i+1;j<=n;j++){
            for(int k=i;k<j;k++)
                if(f[i][k]==f[k+1][j])
                    f[i][j]=max(f[i][j],f[i][k]+1);
            ans=max(ans,f[i][j]);
        }
    cout<<ans;
}

 

以上是关于洛谷 P3146 [USACO16OPEN]248的主要内容,如果未能解决你的问题,请参考以下文章

P3146 [USACO16OPEN]248

[DP 区间 转移限制] P3146 [USACO16OPEN]248 G

luogu P3146 [USACO16OPEN]248

P3146 [USACO16OPEN]248 G

luogu3146 [USACO16OPEN]248

USACO16OPEN 248