hdu 2444 The Accomodation of Students

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 2444 The Accomodation of Students相关的知识,希望对你有一定的参考价值。

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7091    Accepted Submission(s): 3169


Problem Description
There are a group of students. Some of them may know each other, while others don‘t. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don‘t know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 

 

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

 

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 

 

Sample Input
4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6
 

 

Sample Output
No
3
 
 
题意:给定m对认识关系,不可传递
问能否将n的人分成两组,人员互相不认识。
不能分成两组输出No
否则输出最大匹配数

二分图染色+匹配

屠龙宝刀点击就送

#include <cstring>
#include <cstdio>
#include <vector>
#include <queue>
#define N 300
using namespace std;
vector<int>G[N];
bool vis[N],flag;
int Map[N][N],match[N],col[N],cnt,n,m;
int dfs(int x)
{
    for(int i=1;i<=n;++i)
    {
        if(Map[x][i]&&!vis[i])
        {
            vis[i]=1;
            if(!match[i]||dfs(match[i]))
            {
                match[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
bool rs(int x)
{
    queue<int>q;
    q.push(x);
    col[x]=0;
    for(int now;!q.empty();)
    {
        now=q.front();
        q.pop();
        for(int i=0;i<G[now].size();++i)
        {
            int v=G[now][i];
            if(col[v]!=-1) {if(col[now]==col[v]) {flag=1;return true;}}
            else
            {
                col[v]=col[now]^1;
                q.push(v); 
            }
        }
    }
    return false;
}
int main()
{
    for(int last=0;scanf("%d%d",&n,&m)!=EOF;last=n)
    {
        for(int i=1;i<=last;++i) G[i].clear();
        int ans=0;
        flag=false;
        memset(Map,0,sizeof(Map));
        memset(col,-1,sizeof(col));
        memset(match,0,sizeof(match));
        for(int x,y;m--;)
        {
            scanf("%d%d",&x,&y);
            Map[x][y]=1;
            G[x].push_back(y);
            G[y].push_back(x);  
        }
        for(int i=1;i<=n;++i) if(col[i]==-1) if(rs(i)) break;
        if(flag) {printf("No\n");continue;}
        for(int i=1;i<=n;++i)
        {
            memset(vis,0,sizeof(vis));
            ans+=dfs(i);
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

以上是关于hdu 2444 The Accomodation of Students的主要内容,如果未能解决你的问题,请参考以下文章

hdu 2444 The Accomodation of Students

HDU2444 The Accomodation of Students —— 二分图最大匹配

hdu2444The Accomodation of Students

HDU - 2444 The Accomodation of Studentsp[二分图判定,匈牙利算法]

hdu 2444 The Accomodation of Students (判断二分图,最大匹配)

HDU 2444 The Accomodation of Students 二分图判定+最大匹配