poj 2485 Highways

Posted ljbguanli

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj 2485 Highways相关的知识,希望对你有一定的参考价值。

Highways
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11071   Accepted: 3145   Special Judge

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can‘t reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7

8 3

题意:有一些村庄,给出坐标,村庄顺序从1往后加,然后再给出几个相连的村庄!求出为使全部村庄相连且路最短,所须要连接的村庄。

两种代码:

prim:

#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
#define N   1000
#define INF 0xfffffff 
int country,workout;
int x[N],y[N],v[N],per[N];
double map[N][N];
double d(int i,int j)
{
	double c;
	return c=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
}
void prim()
{
	double mincost,cost[N];
	int i,j,next;
	for(i=1;i<=country;i++)
	 {
	 	cost[i]=map[1][i];
	 	v[i]=0;
	 	per[i]=1;//记录此时的中心点 
	 }
	 v[1]=1;
	 for(i=2;i<=country;i++)
	  {
	  	mincost=INF;
	  	for(j=1;j<=country;j++)//寻找近期距离的村庄 
	  	  {
	  	  	if(!v[j]&&mincost>cost[j])
	  	  	{
	  	  		next=j;
	  	  		mincost=cost[j];
			}
			}
			if(map[per[next]][next])
			printf("%d %d\n",per[next],next);
			v[next]=1;
			for(j=1;j<=country;j++)
			{
				if(!v[j]&&cost[j]>map[next][j])
				{
					cost[j]=map[next][j];
					per[j]=next;//更换中心点 
				}
			}
			
	  }
}
int main()
{
	scanf("%d",&country);
	int i,j;
	for(i=1;i<=country;i++)
	 {
	 	scanf("%d%d",&x[i],&y[i]);
	 }
	 for(i=1;i<=country;i++)
	   for(j=i+1;j<=country;j++)
	    {
	    	map[j][i]=map[i][j]=d(i,j);
		}
		scanf("%d",&workout);
		int a,b,c;
		for(i=1;i<=workout;i++)
		 {
		 	scanf("%d%d",&a,&b);
		 	map[b][a]=map[a][b]=0;
		 }
		 prim();
	return 0;
}
克鲁斯卡尔:

#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
#define N   1100
int country,road,workout,set[N];
int x[N],y[N];
struct line
{
	int bg;
	int ed;
	double dis;
}num[N*N];
double d(int i,int j)
{
	double c;
	return c=sqrt((x[i]-x[j])*1.0*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
}
int cmp(line a,line b)
{
	return a.dis<b.dis ;
}
int find(int p)//查找 
{
	int t;
	int child=p;
	while(p!=set[p])
	p=set[p];
	while(child!=p)
	{
		t=set[child];
		set[child]=p;
		child=t;
	 } 
   
	 return p;
//return p==set[p]?p:set[p]=find(set[p]);
}
bool merge(int x,int y)//合并 
{
	    int fx=find(x);
		int fy=find(y);
		if(fx!=fy)
		{
			set[fx]=fy;
			return true;
		}
		return false;
}
int main()
{
	    scanf("%d",&country);
	
		int i,j;
		for(i=1;i<=country;i++)
		 {
		 	set[i]=i;
		 	scanf("%d%d",&x[i],&y[i]);
		 }
		 int a,b,c;
		 scanf("%d",&workout);
		 while(workout--)//假设已经修过,直接合并 
		 {
		 	scanf("%d%d",&a,&b);
		     c=merge(a,b);
		 }
		 int t=0;
		
		 for(i=1;i<country;i++)
		   for(j=i+1;j<=country;j++)
		   {
		   	  num[t].bg =i;
		   	  num[t].ed =j;
		   	  num[t].dis =d(i,j);
		   	  t++;
		   } 
		   sort(num,num+t,cmp);
		   for(i=0;i<t;i++)
		   {
		   	if(merge(num[i].bg ,num[i].ed ))
		   	  {
               printf("%d %d\n",num[i].bg ,num[i].ed );
			  }
		   } 
	
}



以上是关于poj 2485 Highways的主要内容,如果未能解决你的问题,请参考以下文章

POJ 2485 Highways (最小生成树)

Highways POJ 2485Prim

poj 2485 Highways

POJ 2485 Highways (prim)

POJ2485 Highways MST

POJ 2485 Highways 最小生成树 (Kruskal)