POJ 2485 Highways (prim)

Posted Farewell

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 2485 Highways (prim)相关的知识,希望对你有一定的参考价值。

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They‘re planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Input
The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.
Output
For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.
Sample Input
1

3
0 990 692
990 0 179
692 179 0
Sample Output
692
Hint
Huge input,scanf is recommended.

题意:

给所有的城市通上高铁,要使花费最小,求出其中一条高铁最大的花费。

题解:

给的是邻接矩阵,所以用Prim求最小生成树,求解的时候更新最大花费就行了。

#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
int main()
{
    int a,b;
    while(cin>>a>>b,a||b)
    {
        if(a<b)
            swap(a,b);
        int ta=a,tb=b;
        int num=0;
        while(tb)
        {
            if(ta>2*tb||ta%tb==0)
                break;
            ta-=tb;
            num++;
            swap(ta,tb);
        }
        if(num%2==0)
            cout<<"Stan wins"<<endl;
        else
            cout<<"Ollie wins"<<endl;
    }
    return 0;
}

以上是关于POJ 2485 Highways (prim)的主要内容,如果未能解决你的问题,请参考以下文章

POJ #2485 Highways MST中的最大边权

Poj 2485 Highways

POJ-2485 Highways---最小生成树中最大边

POJ2485 Highways (最小生成树)

POJ2485 Highways

POJ 2485 Highways (最小生成树)