poj 1655 Balancing Act

Posted Nico&11101001

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj 1655 Balancing Act相关的知识,希望对你有一定的参考价值。

Balancing Act
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14066   Accepted: 5937

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T. 
For example, consider the tree: 
技术分享

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two. 

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number. 

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

Source

树的重心

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn =  20003;
int m;
struct node{
    int v,next;
}edge[100000];int head[maxn],num;
void add_edge(int x ,int y)
{
    edge[++num].v=y;edge[num].next=head[x];head[x]=num;
}
bool vis[maxn];int son[maxn];
int siz=0x7fffffff,ans;
void dfs(int x)
{
    vis[x]=1;
    son[x]=0;
    int tmp=0;
    for(int i=head[x];i;i=edge[i].next)
    {
        int v=edge[i].v;
        if(vis[v])continue;
        dfs(v);
        son[x]+=(son[v]+1);
        tmp=max(son[v]+1,tmp);
    }
    tmp=max(tmp,m-son[x]-1);
    if(tmp<siz || tmp==siz && ans>x)
    {
        ans=x;
        siz=tmp;
    }
    
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(vis,0,sizeof vis);num=0;siz=0x7fffffff;ans=0;
        memset(head,0,sizeof(head));
        scanf("%d",&m);
        int a,b;
        for(int i=1;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            add_edge(a,b);add_edge(b,a);
        }
        dfs(1);
        printf("%d %d\n",ans,siz);
    }
    return 0;
}

 

以上是关于poj 1655 Balancing Act的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1655 Balancing Act (树的重心)

poj1655 Balancing Act

[POJ1655]Balancing Act

POJ - 1655 Balancing Act (树的重心)

Balancing Act(poj1655)

poj 1655 Balancing Act