codevs2144 砝码称重 2

Posted Code_Together

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了codevs2144 砝码称重 2相关的知识,希望对你有一定的参考价值。

题目描述 Description

有n个砝码,现在要称一个质量为m的物体,请问最少需要挑出几个砝码来称?

注意一个砝码最多只能挑一次

输入描述 Input Description

第一行两个整数n和m,接下来n行每行一个整数表示每个砝码的重量。

输出描述 Output Description

输出选择的砝码的总数k,你的程序必须使得k尽量的小。

样例输入 Sample Input

3 10
5
9
1

样例输出 Sample Output

2

数据范围及提示 Data Size & Hint

1<=n<=30,1<=m<=2^31,1<=每个砝码的质量<=2^30

 
#include<bits/stdc++.h>
using namespace std;
int n,mass,ans=666,f[233];
map<int,int>m;

void dfs(int step,int last,int sum,bool k) {
	int r=n;
	if(k)m[sum]=step,r/=2;
	else if(m.find(mass-sum)!=m.end())ans=min(ans,step+m[mass-sum]);
	for(int i=last;i<r;i++)dfs(step+1,i+1,sum+f[i],k);
}

int main() {
	cin>>n>>mass;
	for(int i=0;i<n;i++)cin>>f[i];
	dfs(0,0,0,true);
	dfs(0,n/2,0,false);
	cout<<ans<<endl;
    return 0;
}

以上是关于codevs2144 砝码称重 2的主要内容,如果未能解决你的问题,请参考以下文章

2144 砝码称重 2

2144 砝码称重 2

1837 砝码称重

练习砝码称重

砝码称重2

51nod 1837 砝码称重数学,规律