Hdu 1097 A hard puzzle

Posted 寂地沉

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Hdu 1097 A hard puzzle相关的知识,希望对你有一定的参考价值。

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43926    Accepted Submission(s): 15961

Problem Description

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b‘s the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

 

 

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

 

 

Output

For each test case, you should output the a^b‘s last digit number.

 

 

Sample Input

7 66

8 800

 

 

Sample Output

9

6

#include<stdio.h>
int ldigit[10][4]={{0},{1},{6,2,4,8},{1,3,9,7},{6,4},{5},{6},{1,7,9,3},{6,8,4,2},{1,9}};
int main()
{
	int a,b;
	int d;
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		d=a%10;
		if(d==0||d==1||d==5||d==6)
			printf("%d\n",d);
		else if(d==4||d==9) 
			printf("%d\n",ldigit[d][b%2]);
		else if(d==2||d==3||d==7||d==8)
			printf("%d\n",ldigit[d][b%4]);
	}
	return 0;
}

  

以上是关于Hdu 1097 A hard puzzle的主要内容,如果未能解决你的问题,请参考以下文章

(HDU)1097 --A hard puzzle(难题)

人生第一个快速幂的题(HDU - 1097--A hard puzzle )

HDOJ-ACM1097(JAVA) A hard puzzle

hdu1097

hdu1098:Ignatius's puzzle

HDU 1097 快速幂