Battle Ships(复习泛化物品**)

Posted 小时のblog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Battle Ships(复习泛化物品**)相关的知识,希望对你有一定的参考价值。

传送门
Battle Ships

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases.
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers t i(1 ≤ t i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input

1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output

2
4
5


Author: FU, Yujun
Contest: ZOJ Monthly, July 2012
 
【题目大意】有l滴血,你有n个战舰,生产每个战舰需要时间,生产后每秒攻击i点血,求耗完l滴血的最少时间。
【code】
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int f[340],protim[40],fi[40];
int n,l,i,j;
int main()
{
    while(scanf("%d%d",&n,&l)!=EOF)
    {
        memset(f,0,sizeof(f));
        for(i=1;i<=n;i++)
        scanf("%d%d",&protim[i],&fi[i]); 
        for(i=1;i<=l;i++)
        for(j=1;j<=n;j++)
        f[i+protim[j]]=max(f[i+protim[j]],f[i]+i*fi[j]);
        for( i=1;i<=340;i++)
        if(f[i]>=l)break;
        printf("%d\n",i);
    }
    return 0;
}

 

以上是关于Battle Ships(复习泛化物品**)的主要内容,如果未能解决你的问题,请参考以下文章

HDU - 5093 Battle ships

CodeForces - 567D One-Dimensional Battle Ships

[HDOJ5093] Battle ships(最大匹配)

Battle ships HDU - 5093二分匹配

51 nod 1521 一维战舰 时间复杂度O(n),同 Codeforces 567D. One-Dimensional Battle Ships 有详细注释

动态规划——泛化物品