NOI-1.1-08-字符三角形

Posted Lab of Oliver

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了NOI-1.1-08-字符三角形相关的知识,希望对你有一定的参考价值。

08:字符三角形

总时间限制: 
1000ms
 
内存限制: 
65536kB
描述

给定一个字符,用它构造一个底边长5个字符,高3个字符的等腰字符三角形。

输入
输入只有一行, 包含一个字符。
输出
该字符构成的等腰三角形,底边长5个字符,高3个字符。
样例输入
*
样例输出
  *
 ***
*****


#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string>
#include <ctype.h>

using namespace std;

int main()  {
    char a;
    scanf("%c", &a);
    for(int i = 1; i <=3; i++)  {
        int num = 2*i-1;
        int kong = (5-num)/2;
        for(int j = 1; j <= kong; j++)  cout << " ";
        for(int j = 1; j <= num; j++)   cout << a;
        for(int j = 1; j <= kong; j++)  cout << " ";
        cout << endl;
    }

    return 0;

}

采用了麻烦一点的方法,为了更有拓展性

以上是关于NOI-1.1-08-字符三角形的主要内容,如果未能解决你的问题,请参考以下文章

为啥这个 CSS 片段可以画一个三角形? [复制]

JavaScript笔试题(js高级代码片段)

片段着色器不会在 OpenGL GLSL 中创建像光一样的渐变

Cg入门16:Fragment shader - 片段级光照

为啥片段着色器没有附加?

openGL 纹理05