POJ 2533 Longest Ordered Subsequence

Posted zsychanpin

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 2533 Longest Ordered Subsequence相关的知识,希望对你有一定的参考价值。

链接:http://poj.org/problem?

id=2533

Longest Ordered Subsequence

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 38875 Accepted: 17066

Description


A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input


The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output


Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7

1 7 3 5 9 4 8


Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion

大意——给一队排列整齐的数列ai,找到数列ai中最长上升子序列的长度。

思路——这是一道很典型的LIS问题。设dp[i]表示以第i个数为后缀的单调序列的最大长度,则dp[0]=1,dp[i+1]= max{1,dp[j]+1|j=0,1,...,i&&a[i+1]>a[j]},max{dp[i]|i=0,...,n-1}即为结果。

复杂度分析——时间复杂度:O(n^2),空间复杂度:O(n)

附上AC代码:


#include <iostream>
#include <cstdio>
#include <string>
#include <cmath>
#include <iomanip>
#include <ctime>
#include <climits>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <map>
using namespace std;
typedef unsigned int UI;
typedef long long LL;
typedef unsigned long long ULL;
typedef long double LD;
const double pi = acos(-1.0);
const double e = exp(1.0);
const int maxn = 1005;
int num[maxn];
int dp[maxn];

int main()
{
	ios::sync_with_stdio(false);
	int n;
	while (scanf("%d", &n) != EOF)
	{
		for(int i=0; i<n; i++)
			scanf("%d", &num[i]);
		dp[0] = 1;
		for (int i=1; i<n; i++)
		{
			dp[i] = 1;
			for (int j=0; j<i; j++)
				if (num[j] < num[i])
					dp[i] = max(dp[i], dp[j]+1);
		}
		int ans = 0;
		for (int i=0; i<n; i++)
			ans = max(ans, dp[i]);
		printf("%d\n", ans);
	}
	return 0;
}


以上是关于POJ 2533 Longest Ordered Subsequence的主要内容,如果未能解决你的问题,请参考以下文章

POJ2533:Longest Ordered Subsequence

POJ 2533 Longest Ordered Subsequence

poj 2533 Longest Ordered Subsequence(LIS)

POJ 2533 Longest Ordered Subsequence(裸LIS)

POJ 2533 Longest Ordered Subsequence DP

POJ - 2533 Longest Ordered Subsequence