POJ 2533 Longest Ordered Subsequence

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 2533 Longest Ordered Subsequence相关的知识,希望对你有一定的参考价值。

题目链接:

http://poj.org/problem?id=2533

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4


Hint:

题意:
最长上升子序列
题解:
DP,还有注意这里的序列并非要连续的。
代码:
#include <cmath>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1000+10;
#define inf 0x3f3f3f3f
#define met(a,b) memeset(a,b,sizeof(a))
int dp[maxn],a[maxn];
int n;
int DP()
{
    for(int i=1;i<=n;i++)
    {
        dp[i]=1;
        for(int j=1;j<i;j++)
            if(a[i]>a[j])
                dp[i]=max(dp[i],dp[j]+1);
    }
    int ans=-inf;
    for(int i=1;i<=n;i++)
    {
        if(dp[i]>ans)
           ans=dp[i];
    }
    return ans;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        int ans=DP();
        printf("%d\n",ans);
    }
}

  

以上是关于POJ 2533 Longest Ordered Subsequence的主要内容,如果未能解决你的问题,请参考以下文章

POJ2533:Longest Ordered Subsequence

POJ 2533 Longest Ordered Subsequence

poj 2533 Longest Ordered Subsequence(LIS)

POJ 2533 Longest Ordered Subsequence(裸LIS)

POJ 2533 Longest Ordered Subsequence DP

POJ - 2533 Longest Ordered Subsequence