hdu 3829 Cat VS Dog 二分图匹配 最大点独立集

Posted xjhz

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 3829 Cat VS Dog 二分图匹配 最大点独立集相关的知识,希望对你有一定的参考价值。

Cat VS Dog

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)



Problem Description
The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child‘s like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child‘s like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.
 

 

Input
The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child‘s like-animal and dislike-animal, C for cat and D for dog. (See sample for details)
 

 

Output
For each case, output a single integer: the maximum number of happy children.
 

 

Sample Input
1 1 2 C1 D1 D1 C1 1 2 4 C1 D1 C1 D1 C1 D2 D2 C1
 

 

Sample Output
1 3
Hint
Case 2: Remove D1 and D2, that makes child 1, 2, 3 happy.
 

 

Source

题意:给你m只狗跟n只猫,p个人,每个人有一只喜欢和不喜欢的动物;

   可以选取一些动物,使得满足条件的人最多;

   满足条件:一个人的喜欢的动物在,并且不喜欢的动物不在;

思路:二分图匹配最大点独立集模型=所有人-最大匹配;

   把所有人的对立的关系连边;

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<iostream>
#include<cstdio>
#include<cmath>
#include<string>
#include<queue>
#include<algorithm>
#include<stack>
#include<cstring>
#include<vector>
#include<list>
#include<set>
#include<map>
#include<stdlib.h>
#include<time.h>
using namespace std;
#define LL long long
#define pi (4*atan(1.0))
#define eps 1e-6
#define bug(x)  cout<<"bug"<<x<<endl;
const int N=1e3+10,M=1e6+10,inf=1e9+10;
const LL INF=5e17+10,mod=1e9+7;

int n,m;
int mp[N][N];
int linker[N];
bool used[N];
bool dfs(int a)
{
    for(int i=0;i<n;i++)
      if(mp[a][i]&&!used[i])
      {
          used[i]=true;
          if(linker[i]==-1||dfs(linker[i]))
          {
              linker[i]=a;
              return true;
          }
      }
      return false;
}
int hungary()
{
    int result=0;
    memset(linker,-1,sizeof(linker));
    for(int i=0;i<n;i++)
    {
        memset(used,0,sizeof(used));
        if(dfs(i))  result++;
    }
    return result;
}
string l[N],disl[N];
int main()
{
    int c,d;
    while(~scanf("%d%d%d",&c,&d,&n))
    {
        memset(mp,0,sizeof(mp));
        for(int i=0;i<n;i++)
        cin>>l[i]>>disl[i];
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(l[i]==disl[j]||disl[i]==l[j])
                    mp[i][j]=1;
            }
        }
        int cnt=hungary();
        printf("%d\n",n-cnt/2);
    }
    return 0;
}

 

以上是关于hdu 3829 Cat VS Dog 二分图匹配 最大点独立集的主要内容,如果未能解决你的问题,请参考以下文章

Cat VS Dog HDU_3829(最大独立集最大匹配)

HDU--3829--Cat VS Dog最大点独立集

HDU3829 Cat VS Dog —— 最大独立集

HDU3829 Cat VS Dog

Cat VS Dog HDU - 3829 (最大独立集 )

HDU3829 Cat VS Dog(最大独立集)