HDU 1018 Big Number (log函数求数的位数)

Posted clnchanpin

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1018 Big Number (log函数求数的位数)相关的知识,希望对你有一定的参考价值。

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
2 10 20
 

Sample Output
7 19
 
123456=1.23456*10^5;
    log10(123456)=5.09151;
    log10(1.23456*10^5)=log10(1.23456)+log10(10^5)=0.09151+5;
    故int(log10(n))+1 就是n的位数 
 1、x的位数=(int)log10(x)+1;
 2、斯特林近似公式:n!≈sqrt(2*π*n)*(n/e)^n。

#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
int main()
{
	int i,t,n;
	double ans;
	cin>>t;
	while(t--){
		cin>>n;
		ans=0;
		for(i=1;i<=n;i++) {
			ans+=log10(double(i));
		}
		printf("%d\n",int(ans)+1);
	}
	return 0;
}


以上是关于HDU 1018 Big Number (log函数求数的位数)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1018 Big Number (log函数求数的位数)

HDU_1018_Big number

HDU 1018 Big Number 数学题

HDU 1018 Big Number

hdu 1018 Big Number 数学结论

HDU 1018:Big Number (位数递推公式)