HDU 1018:Big Number (位数递推公式)

Posted shallow-dream

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1018:Big Number (位数递推公式)相关的知识,希望对你有一定的参考价值。

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output
The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input
2
10
20

Sample Output
7
19

 

#include <cstdio>
#include <string.h>
#define N 1024
#define MAXN 0x3f3f3f3f
#include <map>
#include <string>
#include <cmath>
#define pi acos(-1.0)
#include <algorithm>
#include <iostream>
#include <iomanip>
#include <set>
using namespace std;
int main()
{
    int n,m,t;
    cin>>t;
    while(t--)
    {
        double sum=0;
        cin>>n;
        for(double i=1;i<=n;i++)
            sum+=log10(i);
        cout<<(int)sum+1<<endl;

    }
    return 0;
}

 

以上是关于HDU 1018:Big Number (位数递推公式)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1018 Big Number (log函数求数的位数)

HDU 1018 Big Number (log函数求数的位数)

HDU 1018Big Number(大数的阶乘的位数,利用公式)

HDU 1018 -- Big Number (Stirling公式求n!的位数)

HDU 1018 Big Number

HDU 1018 Big Number