hdu-1001Sum Problem

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu-1001Sum Problem相关的知识,希望对你有一定的参考价值。

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 469658    Accepted Submission(s): 118388


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

 

Input
The input will consist of a series of integers n, one integer per line.
 

 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

 

Sample Input
1 100
 

 

Sample Output
1 5050
 
水题一道,题意就是计算1~n的和,唯一需要注意的是格式问题,每两个输出数据之间要多上一个换行
贴上代码:
# include <stdio.h>
int main ()
{
    int sum,n;
    while(scanf("%d",&n)!=EOF)
    {
        sum=0;
        for(int i=1;i<=n;i++)
        {
            sum+=i;
        }
        printf("%d\n\n",sum);
    }
}

 

以上是关于hdu-1001Sum Problem的主要内容,如果未能解决你的问题,请参考以下文章

hdu-1001Sum Problem

hdu 1001 Sum Problem

hdu 1001 Sum Problem

HDUOJ基础题HDU1001

jAVA HDU1001题

hdu 1000&hdu1001