HDU 1001 Sum Problem

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1001 Sum Problem相关的知识,希望对你有一定的参考价值。

 

Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.


Input
The input will consist of a series of integers n, one integer per line.


Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.


Sample Input
1

100


Sample Output
1

 

5050

 

Author
DOOM III

题意:输入n,求1到n的和

注意:可以用求和公式,int会溢出,每个答案后要有一个空行

#include <stdio.h>
int main()
{
    int n, sum;
    while (scanf("%d", &n)!=EOF)
    {
        sum=0;
        for (int i=1;i <= n; i++)
           sum += i;
        printf("%d\n\n", sum);
     }
   return 0;
 }

 

以上是关于HDU 1001 Sum Problem的主要内容,如果未能解决你的问题,请参考以下文章

hdu-1001Sum Problem

hdu 1001 Sum Problem

hdu 1001 Sum Problem

HDOJ 1001_Sum Problem

[ACM]HDU Problem 1001 + Java

HDUOJ基础题HDU1001