POJ2230(打印欧拉回路)

Posted vCoders

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ2230(打印欧拉回路)相关的知识,希望对你有一定的参考价值。

Watchcow
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 7473   Accepted: 3270   Special Judge

Description

Bessie‘s been appointed the new watch-cow for the farm. Every night, it‘s her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she‘s done. 

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she‘s seen everything she needs to see. But since she isn‘t, she wants to make sure she walks down each trail exactly twice. It‘s also important that her two trips along each trail be in opposite directions, so that she doesn‘t miss the same thing twice. 

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M. 

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1
#include <cstdio>
#include <cstring>
using namespace std;
const int MAXN=100005;
struct Edge{
    int to,net;
}es[MAXN];
int head[MAXN],tot;
int n,m;
void addedge(int u,int v)
{
    es[tot].to=v;
    es[tot].net=head[u];
    head[u]=tot++;
}

int path[MAXN],top;
int vis[MAXN];
void dfs(int u)
{
    for(int i=head[u];i!=-1;i=es[i].net)
    {
        if(!vis[i])
        {
            vis[i]=1;
            dfs(es[i].to);
        }
    }
    path[top++]=u;//必须放在for循环之后 
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(vis,0,sizeof(vis));
        memset(head,-1,sizeof(head));
        tot=0;
        top=0;
        for(int i=0;i<m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            addedge(u,v);
            addedge(v,u);
        }
        dfs(1);
        for(int i=0;i<top;i++)
        {
            printf("%d\n",path[i]);
        }
    }
    return 0;
}

 

以上是关于POJ2230(打印欧拉回路)的主要内容,如果未能解决你的问题,请参考以下文章

poj2230 Watchcow(欧拉回路)

POJ2230 Watchcow - 欧拉回路

poj2230(欧拉路)

POJ2230Watchcow

POJ 2230 Watchcow

ACM/ICPC 之 欧拉回路两道(POJ1300-POJ1386)