习题3-4 周期串 UVa455

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了习题3-4 周期串 UVa455相关的知识,希望对你有一定的参考价值。

Description

A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string "abcabcabcabc" has period 3, since it is formed by 4 repetitions of the string "abc". It also has periods 6 (two repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").

 Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1

HoHoHo

Sample Output

 2

代码实现

 

#include <stdio.h>
#include <string.h>

int isLoopstring(char str[],int a,int b);
int main()
{
    int n,i,k;
    char str[85];
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s",str);
        for(i=1;i<=strlen(str);i++)
        {
            if(strlen(str)%i==0)
            {
                if(isLoopstring(str,i,strlen(str)))
                {
                    k=i;
                    break;
               }
            }
         }
        if(n==0)
            printf("%d\n",k);
        else
            printf("%d\n\n",k);
    }
    return 0;
}

int isLoopstring(char str[],int a,int b)
{
    int i,j,flag=1;
    for(i=0;i<a;i++)
    {
        for(j=i+a;j<b;j+=a)
        {
            if(str[j]!=str[i])
            {
                flag=0;
                return 0;
            }
        }
     }
    if(flag) return 1;
}

 

以上是关于习题3-4 周期串 UVa455的主要内容,如果未能解决你的问题,请参考以下文章

算法竞赛入门经典题解——第三章 3-4 周期串UVa455

UVA - 455(周期串)

UVa455 周期串

(UVA)455 --Periodic Strings(周期串)

UVA455Periodic Strings(最小周期串)

UVA455 周期串(Periodic Strings)