Bone Collector

Posted SDAU_ZG

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Bone Collector相关的知识,希望对你有一定的参考价值。

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
 
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
 
Sample Output
14
 
思路:01背包问题,这种背包特点是:每种物品仅有一件,可以选择放或不放。用子问题定义状态:即F[i;v] 表示前i 件物品

恰放入一个容量为v的背包可以获得的最大价值。则其状态转移方程便是:
则其状态转移方程便是:
dp[i][v]=max{dp[i-1][v],dp[i-1][v-cost[i]]+value[i]}

代码:

#include<iostream>
#include<string.h>
using namespace std;
const int NUM = 1009;
typedef struct pack
{
int cost;
int val;
}PACK;
int f[NUM][NUM];
int main()
{
int cas,n,v,i,j;

PACK a[NUM];
cin >> cas;
while(cas--)
{
  cin >> n >> v;
  memset(f,0,sizeof(f));
  for(i=1;i<=n;i++)
    cin >> a[i].val;
  for(i=1;i<=n;i++)
    cin >> a[i].cost;
  for(i=1;i<=n;i++)
  for(j=0;j<=v;j++)
    if(j-a[i].cost>=0&&f[i-1][j]<f[i-1][j-a[i].cost]+a[i].val)
      f[i][j]=f[i-1][j-a[i].cost]+a[i].val;
    else
      f[i][j]=f[i-1][j];
    cout << f[n][v] << endl;
  }
  return 0;
}

以上是关于Bone Collector的主要内容,如果未能解决你的问题,请参考以下文章

Bone Collector II(HDU 2639 DP)

css 自举响应,bone.css

Bone Collector

Bone Collector HDU - 2602

Bone collector//动态规划

ACM Bone Collector