DS树--二叉树高度

Posted szu-ds-wys

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了DS树--二叉树高度相关的知识,希望对你有一定的参考价值。

题目描述

给出一棵二叉树,求它的高度。二叉树的创建采用前面实验的方法。

注意,二叉树的层数是从1开始

 

 

输入

 

第一行输入一个整数t,表示有t个二叉树

第二行起输入每个二叉树的先序遍历结果,空树用字符‘0’表示,连续输入t行

 

输出

每行输出一个二叉树的高度

 

 

样例输入

1 AB0C00D00

样例输出

3

提示

#include<iostream>
#include<string>
using namespace std;
class BiTreeNode
{
public:
    char data;
    BiTreeNode *Left;
    BiTreeNode *Right;
    BiTreeNode()
    {
        Left=NULL;
        Right=NULL;
    }
    ~BiTreeNode()
    {
        delete Left;
        delete Right;
    }
};
 
class BiTree
{
public:
    BiTreeNode *Root;
    int pos;
    string strTree;
    int deep;
    BiTree(string str)
    {
        pos=0;
        deep=0;
        strTree=str;
        Root=CreateBiTree();
    }
    BiTreeNode *CreateBiTree()
    {
        char ch=strTree[pos];
        pos++;
        if(ch==0)
        {
            return NULL;
        }
        else
        {
            BiTreeNode *T;
            T=new BiTreeNode();
            T->data=ch;
            T->Left=CreateBiTree();
            T->Right=CreateBiTree();
            return T;
        }
    }
    void countdeep(BiTreeNode *p,int i)
    {
        if(p)
        {
            i++;
            if(p->Left==NULL&&p->Right==NULL)
            {
                if(deep<i)
                    deep=i;
            }
            countdeep(p->Left,i);
            countdeep(p->Right,i);
        }
    }
};
 
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        string str;
        cin>>str;
        BiTree tree(str);
        tree.countdeep(tree.Root,0);
        cout<<tree.deep<<endl;
    }
    return 0;
}

以上是关于DS树--二叉树高度的主要内容,如果未能解决你的问题,请参考以下文章

二叉树练习实验

问题 D: DS查找—二叉树平衡因子(不一样的新做法哦)

DS二叉树—二叉树结点的最大距离

判断一颗二叉树是否为二叉平衡树 python 代码

DS二叉树—二叉树构建与遍历(不含框架)

DS二叉树—二叉树镜面反转