1027 Colors in Mars (20分)

Posted qinmin

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1027 Colors in Mars (20分)相关的知识,希望对你有一定的参考价值。

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71
 

Sample Output:

#123456


10进制转13进制,用除法,且结果最多两位。
所以可以使用一个字符串来存储每一位的结果
将10进制的每一位用13进制来表示,然后去字符串中找对应的结果并输出


#include<iostream>
using namespace std;
int main()
{
    string a ={"0123456789ABC"};//用一个字符串来存储要输出的结果
    int num1,num2,num3;
    while(scanf("%d %d %d",&num1,&num2,&num3))
    {
        printf("#");
        printf("%c%c%c%c%c%c",a[num1/13],a[num1%13],a[num2/13],a[num2%13],a[num3/13],a[num3%13]);
    }

    return 0;
}

 

以上是关于1027 Colors in Mars (20分)的主要内容,如果未能解决你的问题,请参考以下文章

PAT 甲级 1027 Colors in Mars (20 分)

1027 Colors in Mars (20分)

1027 Colors in Mars (20分)

PAT 甲级 1027 Colors in Mars (20 分)(简单,进制转换)

PAT Advanced 1027 Colors in Mars (20分)

PAT 1027 Colors in Mars (20分)