1068 Find More Coins (30 分)
Posted Keep--Silent
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1068 Find More Coins (30 分)相关的知识,希望对你有一定的参考价值。
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤104 , the total number of coins) and M (≤102, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the face values V 1 ≤V2≤⋯≤V k such that V 1+V 2+⋯+V k=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output “No Solution” instead.
Note: sequence {A[1], A[2], …} is said to be “smaller” than sequence {B[1], B[2], …} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].
Sample Input 1:
8 9 5 9 8 7 2 3 4 1
Sample Output 1:
1 3 5
Sample Input 2:
4 8 7 2 4 3
Sample Output 2:
No Solution
题目大意:给n个数和给出m。要求选一些数,使得这些数的和等于给定的m.
如果只是输出No Solution的话,我们可以看到:
也就是说,第一个测试点和第六个测试点无解。
接下来暴力做题:
从小到大排序
dfs每个数,每个数选或不选(看到这里,其实应该知道正解是dp了)
dfs过程中要记得剪枝,如果前面的数和已经大于需要的数,那么返回,不必再往下搜了
6超时了
但是我们知道6是无解的。
加上对运行时间的处理:如果快超时了,那么退出搜索
head = clock();
tail = clock();
if ((double)(tail - head) / CLOCKS_PER_SEC > 0.17)return;
完整代码:
#include <bits/stdc++.h>
using namespace std;
const int SIZE = 10220;
int num[SIZE];
int ans[SIZE];
int k;
clock_t head, tail;
void dfs(int i, int n, int cnt) {
//printf("i=%d,cnt=%d k=%d\\n",i,cnt,k);
tail = clock();
if ((double)(tail - head) / CLOCKS_PER_SEC > 0.17)return;
if (cnt == 0) {
for (int i = 0; i < k; i++) {
printf("%d", ans[i]);
if (i == k - 1)cout << endl;
else printf(" ");
}
exit(0);
}
else {
if (i == n || num[i] > cnt)return;
ans[k++] = num[i];
dfs(i + 1, n, cnt - num[i]);
k--;
dfs(i + 1, n, cnt);
}
}
int main() {
int n, i, j, m;
cin >> n >> m;
for (i = 0; i < n; i++)scanf("%d", &num[i]);
head = clock();
sort(num, num + n);
dfs(0, n, m);
printf("No Solution\\n");
return 0;
}
评价:
暴力解题……
面向数据编程…
以上是关于1068 Find More Coins (30 分)的主要内容,如果未能解决你的问题,请参考以下文章
PAT 甲级 1068 Find More Coins (30 分) (dp,01背包问题记录最佳选择方案)***
PAT甲级1068 Find More Coins (30 分)(背包/DP)