JavaScript输入几个数构成的数列,输入n行,每一次输出都把最后一个数提前到第一位
Posted
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了JavaScript输入几个数构成的数列,输入n行,每一次输出都把最后一个数提前到第一位相关的知识,希望对你有一定的参考价值。
比如输出3行,数列为1.2.3.4.5
1.2.3.4.5
5.1.2.3.4
4.5.1.2.3
3.4.5.1.2
具体要求如图
这道题主要学习javascript数组的操作,添加删除和字符串的相互转换,代码如下:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>第2题答案</title>
</head>
<body>
<div>数列:<input type="text" id="shulie" /></div>
<div>行数:<input type="text" id="num" style="width:40px;" /></div>
<div>显示:<textarea id="show" rows="10" cols="60"></textarea></div>
<div>
<input type="button" id="bt" value="显示" />
<input type="button" id="clear" value="清空" />
</div>
<script language="javascript">
//显示
document.getElementById("bt").onclick=function()
var shulie=document.getElementById('shulie').value;
var num=parseInt(document.getElementById('num').value);
//数据的验证
if(shulie=='' || num<1)
window.alert("请填写数列");
document.getElementById('shulie').focus();
return ;
if(num<1)
window.alert("请填写一个大于0的数字");
document.getElementById('num').focus();
return ;
//按字符分隔,如果数列是逗号,就把它修改成逗号
var arr=shulie.split('');
//第一行是原数列
var text=arr.join(" ");
for(var i=1;i<num;i++)
//删除并返回最后一个元素
var last=arr.pop();
//像输入开头添加一个元素
arr.unshift(last);
//拼接一个换行符
text+="\\r\\n";
//把输入数组按空格拆分成字符串,连接到text
text+=arr.join(" ");
document.getElementById('show').value=text;
;
//清空
document.getElementById("clear").onclick=function()
//清空数列
document.getElementById('shulie').value='';
//清空行数
document.getElementById('num').value='';
//清空显示
document.getElementById('show').value='';
</script>
</body>
</html> 参考技术A 第一个有人写了,我来写那个补充题吧:
#include<iostream>
#include<conio.h>
using namespace std;
struct Jose
iint code;
Jose* next;
;
int n, s, m;
Jose *pCur, *pivot;
bool getValue();
Jose* createRing();
void countBoy(int m);
void process();
int main()
if(!getValue()) return 1;
Jose* pJose = createRing();
process();
cout<<"\nThe winner is "<<pCur->code<<"\n";
delete[] pJose;
getch();
bool getValue()
cout<<"please input boyNumber, startPosition, intervalNumber: \n";
cin>>n>>s>>m;
if(n>=2 && s>=1 && s<=n && m>=1 && m<=m) return true;
cerr<<"failed in bad boyNumber or startPosition or intervalNumber.\n";
return false;
Jose* createRing()
Jose* px = new Jose[n];
for(int i=1; i<=n; ++i)
px[i-1].next = &px[i%n];
px[i-1].code = i;
cout<<"There are "<<n<<" boys.\n";
pivot = & px[n-2];
pCur = &px[n-1];
countBoy(s-1);
return px;
void countBoy(int m)
for(int i=0; i<m; ++i)
pivot = pCur;
pCur = pivot->next;
void process()
for(int i=1; i<n; ++i)
countBoy(m);
static int line=0;
cout<<" "<<pCur->code;
if(!(++line%10)) cout<<"\n";
pivot->next = pCur->next;
pCur = pivot;
这个应该就是你说的功能了。追问
大佬,会js的做法嘛?
参考技术B <!DOCTYPE html><html>
<head>
<meta charset="UTF-8">
<title>Document</title>
</head>
<body>
<input type="text"><br>
<input type="text"><br>
<input type="text"><br>
<input type="button" value="确认">
</body>
<script>
var inps = document.querySelectorAll("input");
inps[3].onclick = function()
alert(Math.max(inps[0].value,inps[1].value,inps[2].value));
//得到的.value是string型的,需要转换为number
var a = Number(inps[0].value);
var b = Number(inps[1].value);
var c = Number(inps[2].value);
if(a>b)
if(a>c)
alert(a);
else
alert(c);
else
if(b>c)
alert(b);
else
alert(c);
// 枚举法 列举所有可能
if(a>=b && a>=c)
alert(a);
if(b>=a && b>=c)
alert(b);
if(c>=a && c>=b)
alert(c);
//定义中间变量,定义最大值
var max = 0;
if(a >= max)
max = a;
if(b >= max)
max = b;
if(c >= max)
max = c;
alert(max);
</script>
</html>追问
大佬,这个不是输出最大数啊,题目不够详细嘛?
参考技术C function seq(row, arrNum)console.log(arrNum);
while(row--)
arrNum.unshift(arrNum.pop());
console.log(arrNum);
seq(3, [1, 2, 3, 4, 5]);追问
大佬,如果不是输出3行,是输出任意行呢,行数由人定的,可不可以给全代码呀
参考技术D function repL(arr,n)if(Object.prototype.toString.call(arr)!=="[object Array]"||Object.prototype.toString.call(n)!=="[object Number]")
console.log('type is wrong?')
return false
let i=0;
for(;i<n;i++)
arr.splice(0,0,arr[arr.length-1]);
arr.pop();
console.log(arr);
PTA(Basic Level)1030.完美数列
给定一个正整数数列,和正整数 p,设这个数列中的最大值是 M,最小值是 m,如果 M≤*m**p*,则称这个数列是完美数列。
现在给定参数 p 和一些正整数,请你从中选择尽可能多的数构成一个完美数列。
输入格式:
输入第一行给出两个正整数 N 和 p,其中 N(≤105)是输入的正整数的个数,p(≤109)是给定的参数。第二行给出 N 个正整数,每个数不超过 109。
输出格式:
在一行中输出最多可以选择多少个数可以用它们组成一个完美数列。
输入样例:
10 8
2 3 20 4 5 1 6 7 8 9
输出样例:
8
思路
- 比较朴素的想法是:二重循环枚举数列(排序后),注意优化就不会
TLE
- 还有注意运算范围显然超过了
int
的上限,所以要使用long long
代码
#include<bits/stdc++.h>
using namespace std;
int a[100100];
int main()
int N;
long long p;
scanf("%d%ld", &N, &p);
for(int i=0;i<N;i++)
scanf("%d", &a[i]);
sort(a, a+N);
int ans = 0;
for(int i=0;i<N;i++)
for(int j=i+ans;j<N;j++) //这里j从i+ans开始找是一个很重要的优化,因为数组是有序的,我们这么找只要找让答案最长的数列就好了
if(a[j] <= a[i] * p)
ans = max(ans, j-i+1);
else break;
printf("%d\n", ans);
return 0;
引用
https://pintia.cn/problem-sets/994805260223102976/problems/994805291311284224
以上是关于JavaScript输入几个数构成的数列,输入n行,每一次输出都把最后一个数提前到第一位的主要内容,如果未能解决你的问题,请参考以下文章