[PTA]实验10-8 递归计算P函数

Posted Spring-_-Bear

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]实验10-8 递归计算P函数相关的知识,希望对你有一定的参考价值。

本题要求实现下列函数P(n,x)的计算,其函数定义如下:

在这里插入图片描述
函数接口定义:

double P( int n, double x );

其中n是用户传入的非负整数,x是双精度浮点数。函数P返回P(n,x)函数的相应值。题目保证输入输出都在双精度范围内。

裁判测试程序样例:

#include <stdio.h>

double P( int n, double x );

int main()
{
    int n;
    double x;

    scanf("%d %lf", &n, &x);
    printf("%.2f\\n", P(n,x));

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

10 1.7

输出样例:

3.05
  • 提交结果:

在这里插入图片描述

  • 源码:
#include <stdio.h>

double P(int n, double x);

int main()
{
    int n;
    double x;

    scanf("%d %lf", &n, &x);
    printf("%.2f\\n", P(n, x));

    return 0;
}


/* 你的代码将被嵌在这里 */
double P(int n, double x)
{
    double result;

    if (n == 0)
    {
        result = 1;
    }
    else if (n == 1)
    {
        result = x;
    }
    else if (n > 1)
    {
        result = 1.0 / n * ((2 * n - 1) * P(n - 1, x) - (n - 1) * P(n - 2, x));
    }

    return result;
}

以上是关于[PTA]实验10-8 递归计算P函数的主要内容,如果未能解决你的问题,请参考以下文章

[PTA]实验10-3 递归求阶乘和

[PTA]实验10-4 递归实现指数函数

[PTA]习题10-8 递归实现顺序输出整数

[PTA]实验10-5 递归求简单交错幂级数的部分和

[PTA]实验10-10 递归实现顺序输出整数

[PTA]实验10-7 递归求Fabonacci数列