[PTA]实验10-7 递归求Fabonacci数列
Posted Spring-_-Bear
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]实验10-7 递归求Fabonacci数列相关的知识,希望对你有一定的参考价值。
本题要求实现求Fabonacci数列项的函数。Fabonacci数列的定义如下:
f(n)=f(n−2)+f(n−1) (n≥2),其中f(0)=0,f(1)=1。
函数接口定义:
int f( int n );
函数f应返回第n个Fabonacci数。题目保证输入输出在长整型范围内。建议用递归实现。
裁判测试程序样例:
#include <stdio.h>
int f( int n );
int main()
{
int n;
scanf("%d", &n);
printf("%d\\n", f(n));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
6
输出样例:
8
- 提交结果:
- 源码:
#include <stdio.h>
int f(int n);
int main()
{
int n;
scanf("%d", &n);
printf("%d\\n", f(n));
return 0;
}
/* 你的代码将被嵌在这里 */
int f(int n)
{
if (n == 0)
{
return 0;
}
else if (n == 1)
{
return 1;
}
else
{
return f(n - 1) + f(n - 2);
}
}
以上是关于[PTA]实验10-7 递归求Fabonacci数列的主要内容,如果未能解决你的问题,请参考以下文章