c语言 平面n个点坐标,计算各点间距离之和(struct coordinative)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了c语言 平面n个点坐标,计算各点间距离之和(struct coordinative)相关的知识,希望对你有一定的参考价值。

编程 输入平面上n(3<n<=10)个点的坐标,计算各点的距离之和。
坐标点的的类型定义和相应的数组定义为:
struct cpprdinative
float x;
float y;
point[10];

输入输出:
n=10
63,22 56,25 50,30 42,37 53,45
60,55 70,55 76,49 80,40 72,28
Distance=1029.56

参考技术A #include "stdio.h"
#include "math.h"
struct cpprdinative
float x;
float y;
point[10];
void main()

int n = 0;
printf("n=");scanf("%d", &n);
for(int i = 0;i < n; i ++)

scanf("%f,%f", &point[i].x, &point[i].y);

float Distance =0;
for(int i = 0; i < n; i ++)

for(int j = i+1; j < n;j ++)

Distance += sqrt((point[i].x-point[j].x)*(point[i].x-point[j].x)+ (point[i].y-point[j].y)*(point[i].y-point[j].y));


printf("Distance = %f", Distance);

// 输入
n=10
63,22
56,25
50,30
42,37
53,45
60,55
70,55
76,49
80,40
72,28
// 输出
Distance = 1029.568237本回答被提问者采纳
参考技术B 是两点间的距离还是啥

5-3 两点间距离计算

给出下面的一个基类框架:

class Point_1D

{ protected:

float x;//1D 点的x坐标

public:

Point_1D(float p = 0.0);

float distance(const Point_1D & p2);

}

以Point_1D为基类建立一个派生类Point_2D,增加一个保护数据成员:

float y;//2D平面上点的y坐标

以Point_2D为直接基类再建立一个派生类Point_3D,增加一个保护数据成员:

float z;//3D立体空间中点的z坐标

生成上述类并编写主函数,根据输入的点的基本信息,建立点对象,并能计算该点到原点的距离。

输入格式: 测试输入包含若干测试用例,每个测试用例占一行(点的类型(1表示1D点,2表示2D点,3表示3D点) 第一个点坐标信息(与点的类型相关) 第二个点坐标信息(与点的类型相关))。当读入0时输入结束,相应的结果不要输出。

输入样例:

1 -1 0

2 3 4 0 0

3 1 2 2 0 0 0

0

输出样例:

Distance from Point -1 to Point 0 is 1

Distance from Point(3,4) to Point(0,0) is 5

Distance from Point(3,3,3) to Point(0,0,0) is 3

参考代码

#include<iostream>
#include<math.h>
using namespace std;
//本题考察多层继承,将数据设为保护类,并使用公有继承 
//建立一维类 
class Point_1D
{  
protected:
    float x;//1D 点的x坐标
public:
    void set_1D(){cin>>x;}
    float distance(const Point_1D & p2);
};
//建立二维类 
class Point_2D:public Point_1D
{
protected:
    float y;//2D平面上点的y坐标
public:
    void set_2D(){set_1D();cin>>y;}//调用基类set方法 
    float distance(const Point_2D & p2);
};
//建立三维类 
class Point_3D:public Point_2D
{
protected:
    float z;//3D立体空间中点的z坐标
public:
    void set_3D(){set_2D();cin>>z;}
    float distance(const Point_3D & p2);
};
int main()
{
    int type;
    Point_1D a1,a2;
    Point_2D b1,b2;
    Point_3D c1,c2;
    cin>>type;
    while(type)
    {
      switch(type)
      {
        case 1:a1.set_1D();a2.set_1D();a1.distance(a2);break;
        case 2:b1.set_2D();b2.set_2D();b1.distance(b2);break;
        case 3:c1.set_3D();c2.set_3D();c1.distance(c2);break;
      }
      cin>>type;
    }
    return 0;
}
//实现distance方法 &重载 
float Point_1D::distance(const Point_1D & p2)
{
      float a;
      a=fabs(x-p2.x);
      cout<<"Distance from Point "<<x<<" to Point "<<p2.x<<" is "<<a<<endl;
      return a;
}
float Point_2D::distance(const Point_2D & p2)
{
      float a;
      a=sqrt((x-p2.x)*(x-p2.x)+(y-p2.y)*(y-p2.y));
      cout<<"Distance from Point("<<x<<","<<y<<") to Point("<<p2.x<<","<<p2.y<<") is "<<a<<endl;
      return a;
}
float Point_3D::distance(const Point_3D & p2)
{
      float a;
      a=sqrt((x-p2.x)*(x-p2.x)+(y-p2.y)*(y-p2.y)+(z-p2.z)*(z-p2.z));
      cout<<"Distance from Point("<<x<<","<<y<<","<<z<<") to Point("<<p2.x<<","<<p2.y<<","<<p2.z<<") is "<<a<<endl;
      return a;
}

 

欢迎指教,一起学习!

未经本人允许,请勿转载!

谢谢!

以上是关于c语言 平面n个点坐标,计算各点间距离之和(struct coordinative)的主要内容,如果未能解决你的问题,请参考以下文章

用c语言计算两点间的距离

C语言:输入N,再输入N个点的平面坐标,然后输出那些距坐标原点不超过5的坐标值

坐标轴上两点间距离公式是啥?

什么是两点之间的距离 什么定义

已知直线终点与起点坐标 怎么两点距离

5-3 两点间距离计算