HDOJ/HDU 1161 Eddy's mistakes(大写字母转换成小写字母)

Posted 谙忆

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDOJ/HDU 1161 Eddy's mistakes(大写字母转换成小写字母)相关的知识,希望对你有一定的参考价值。

Problem Description
Eddy usually writes articles ,but he likes mixing the English letter uses, for example “computer science” is written frequently “coMpUtEr scIeNce” by him, this mistakes lets Eddy’s English teacher be extremely discontentment.Now please you to write a procedure to be able in the Bob article English letter to turn completely the small letter.

Input
The input contains several test cases.each line consists a test case,Expressed Eddy writes in an article , by letter, blank space,numeral as well as each kind of punctuation
composition, the writing length does not surpass 1000 characters.

Output
For each test case, you should output an only line, after namely the result of transforms the lowercase letter.

Sample Input
weLcOmE tO HDOj Acm 2005!

Sample Output
welcome to hdoj acm 2005!

恩。。大水题~如题,就是把大写字母转换成小写字母。

import java.util.Scanner;

public class Main{

    public static void main(String[] args) {
        Scanner sc =new Scanner(System.in);
        while(sc.hasNext()){
            String str =sc.nextLine();
            System.out.println(str.toLowerCase());
        }
    }
}

以上是关于HDOJ/HDU 1161 Eddy's mistakes(大写字母转换成小写字母)的主要内容,如果未能解决你的问题,请参考以下文章

HDOJ/HDU 2203 亲和串(简单的判断~Java的indexOf()方法秒)

HDOJ/HDU 2140 Michael Scofield's letter(字符转换~)

HDOJ/HDU 1250 Hat's Fibonacci(大数~斐波拉契)

Eddy's picture(最小生成树)

杭电acm 1210 Eddy's 洗牌问题

Eddy's picture