1146. Topological Order (25)

Posted zil17

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1146. Topological Order (25)相关的知识,希望对你有一定的参考价值。

1146. Topological Order (25)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

技术分享图片

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (<= 1,000), the number of vertices in the graph, and M (<= 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (<= 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4

题解代码:

#include <bits/stdc++.h>
using namespace std;
vector<int> v[1024];
int indegree[1024];
bool isTopological(vector<int> &vx)
{
    int n=vx.size();
    vector<int> in(indegree,indegree+n+1);
    for(int x:vx){
        if(in[x]!=0) return 0;
        for(int y:v[x]){
            in[y]--;
        }
    }
    return 1;
}
int main()
{
    int n,m;
    scanf("%d %d",&n,&m);
    for(int i=0;i<m;++i){
        int x,y;
        scanf("%d %d",&x,&y);
        v[x].push_back(y);
        indegree[y]++;
    }
    int k;
    scanf("%d",&k);
    vector<int> res;
    for(int i=0;i<k;++i){
        vector<int> vx;
        for(int i=0;i<n;++i){
            int x;
            scanf("%d",&x);
            vx.push_back(x);
        }
        if(!isTopological(vx)) res.push_back(i);
    }
    int w=res.size();
    for(int x:res)
        --w?printf("%d ",x):printf("%d\n",x);
    return 0;
}

 

以上是关于1146. Topological Order (25)的主要内容,如果未能解决你的问题,请参考以下文章

1146 Topological Order (25 分)判断拓扑序列

PAT 1146 Topological Order

PAT 1146 Topological Order

1146 Topological Order (25分)

PAT甲级——1146 Topological Order (25分)

PAT Advanced 1146 Topological Order (25) [拓扑排序]