Euclid's Game

Posted minxuan

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Euclid's Game相关的知识,希望对你有一定的参考价值。

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 7   Accepted Submission(s) : 6
Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):
         25 7

11 7
4 7
4 3
1 3
1 0

an Stan wins.
 
Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
 
Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.
 
Sample Input
34 12
15 24
0 0
 
Sample Output
Stan wins
Ollie wins
 
#include<iostream>
#include<algorithm>
using namespace std;

int main()
{
	int n,m;
	while(cin>>n>>m)
	{
		if(n==0&&m==0)break;
		int cnt=0;
        int ans=0;
        while(1)
		{
           if(n<m)swap(n,m);
           ans=n/m;
           if(ans>=2)break;
           cnt++;
           n%=m;
           if(n==0)
		   {
               cnt++;
               break;
           }                
        }
       if(cnt%2==1)cout<<"Ollie wins"<<endl;
       else cout<<"Stan wins"<<endl;;
   }
   return 0;
 } 

  

以上是关于Euclid's Game的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1525 Euclid's Game 博弈

POJ2348 Euclid's Game

博弈论Euclid's Game

HDU1525(Euclid's Game)规律博弈

POJ 2348 Euclid's Game 博弈论

[poj2348]Euclid's Game(鍗氬紙璁?gcd)