poj2478 (欧拉函数)

Posted ACRykl

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj2478 (欧拉函数)相关的知识,希望对你有一定的参考价值。

Farey Sequence
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 17894   Accepted: 7179

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

分析:这题很明显的欧拉函数啊,F(N)就是欧拉函数的前N项和(不包括1)。

技术分享图片
#include<cstdio>
long long a[1000100];
void Euler()
{
    for(int i=1;i<1000001;i++) a[i]=i;
    for(int i=2;i<1000001;i++)
    {
        if(a[i]==i)
        {
            for(int j=i;j<1000001;j+=i)
            a[j]=a[j]/i*(i-1);
        }
    }
    for(int i=3;i<1000001;i++) a[i]+=a[i-1];//从3开始
}

int main()
{
    int N;
    Euler();
    while(scanf("%d",&N)&&N)
        printf("%lld\n",a[N]);
    return 0;
}
View Code

 















以上是关于poj2478 (欧拉函数)的主要内容,如果未能解决你的问题,请参考以下文章

poj2478 (欧拉函数)

poj2478-Farey Sequence递推求欧拉函数-欧拉函数的几个性质和推论

POJ-2478-Farey Sequence(欧拉函数)

poj-2478 Farey Sequence(dp,欧拉函数)

筛法求欧拉函数(poj2478

poj2478Farey Sequence