PAT 1005. Spell It Right

Posted A-Little-Nut

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT 1005. Spell It Right相关的知识,希望对你有一定的参考价值。

PAT 1005. Spell It Right (20)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

代码如下

#include<iostream>
#include<vector>
using namespace std;
int main(){
    vector<string> map{"zero","one","two","three","four",
                       "five","six","seven","eight","nine"};
    string s;
    cin>>s;
    int sum=0;
    for(int i=0;i<s.size();i++)
    sum+=s[i]-'0';
    s=to_string(sum);
    for(int i=0;i<s.size();i++)
    i>0?cout<<" "<<map[s[i]-'0']:cout<<map[s[i]-'0'];
    return 0;
}

以上是关于PAT 1005. Spell It Right的主要内容,如果未能解决你的问题,请参考以下文章

PAT A1005 Spell It Right

1005. Spell It Right(20)—PAT 甲级

PAT 甲级 1005 Spell It Right

PAT Advanced 1005 Spell It Right

PAT 甲级 1005 Spell It Right (20 分)

PAT甲级1005 Spell It Right