1005. Spell It Right(20)—PAT 甲级

Posted endlessp162096

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1005. Spell It Right(20)—PAT 甲级相关的知识,希望对你有一定的参考价值。

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

题目大意:求一个整数所有位上的数字之和,并用英文对应数字的每一位表示出来。
分析:因为N的位数高达100位,所以用字符串输入并遍历字符串得到所有数字的和,利用c++自带的to_string函数将和转化为整数类型,最后利用常量数组进行输出转换。

#include <iostream>
#include <string>
using namespace std;
const string num[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
int main() {
    string str;
    int sum=0;
    cin>>str;
    for(auto c:str) {
        sum+=c-'0';
    }
    string s=to_string(sum);
    for(auto c:s) {
        if(c!=s.front()) cout<<" ";
        cout<<num[c-'0'];
    }
    cout<<endl;
    return 0;
}

以上是关于1005. Spell It Right(20)—PAT 甲级的主要内容,如果未能解决你的问题,请参考以下文章

1005. Spell It Right (20)

1005. Spell It Right (20)

1005. Spell It Right (20)

1005. Spell It Right (20)

1005. Spell It Right (20)(模拟题)

1005. Spell It Right(20)—PAT 甲级